aboutsummaryrefslogtreecommitdiff
path: root/print/hugelatex/Makefile
diff options
context:
space:
mode:
authorMurray Stokely <murray@FreeBSD.org>2001-09-08 01:06:06 +0000
committerMurray Stokely <murray@FreeBSD.org>2001-09-08 01:06:06 +0000
commitcc453cdb5c5688015b37624e39d64f8b99734277 (patch)
tree855057d83ca0fccf1bfc09b1627fce04343f8d22 /print/hugelatex/Makefile
parentf70925bdbc97dae9dfcc6bcb7147e73265d50b56 (diff)
downloadports-cc453cdb5c5688015b37624e39d64f8b99734277.tar.gz
ports-cc453cdb5c5688015b37624e39d64f8b99734277.zip
Notes
Diffstat (limited to 'print/hugelatex/Makefile')
-rw-r--r--print/hugelatex/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/print/hugelatex/Makefile b/print/hugelatex/Makefile
new file mode 100644
index 000000000000..a9970919d270
--- /dev/null
+++ b/print/hugelatex/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: hugelatex
+# Date created: 7 September 2001
+# Whom: Murray Stokely <murray@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# $NetBSD: Makefile,v 1.3 2001/09/02 19:51:38 hubertf Exp $
+#
+
+PORTNAME= hugelatex
+PORTVERSION= 1.0
+CATEGORIES= print
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= murray@FreeBSD.org
+
+BUILD_DEPENDS= tex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+TEXMF_CNF= ${LOCALBASE}/share/texmf/web2c/texmf.cnf
+
+do-install:
+ ${CP} -p ${TEXMF_CNF} ${TEXMF_CNF}-before-hugelatex
+ ${CAT} ${FILESDIR}/texmf.cnf-add >>${TEXMF_CNF}
+ cd `dirname ${TEXMF_CNF}`; \
+ ${ECHO} "" | ${PREFIX}/bin/latex -ini -fmt=hugelatex -progname=hugelatex latex.ini || ${TRUE}; \
+ ${RM} -f texsys.aux
+ ${RM} -f ${PREFIX}/bin/hugelatex
+ ${LN} -s latex ${PREFIX}/bin/hugelatex
+ ${PREFIX}/bin/mktexlsr
+
+.include <bsd.port.mk>