aboutsummaryrefslogtreecommitdiff
path: root/print/hugelatex
diff options
context:
space:
mode:
authorMurray Stokely <murray@FreeBSD.org>2001-09-08 01:06:06 +0000
committerMurray Stokely <murray@FreeBSD.org>2001-09-08 01:06:06 +0000
commitcc453cdb5c5688015b37624e39d64f8b99734277 (patch)
tree855057d83ca0fccf1bfc09b1627fce04343f8d22 /print/hugelatex
parentf70925bdbc97dae9dfcc6bcb7147e73265d50b56 (diff)
downloadports-cc453cdb5c5688015b37624e39d64f8b99734277.tar.gz
ports-cc453cdb5c5688015b37624e39d64f8b99734277.zip
Notes
Diffstat (limited to 'print/hugelatex')
-rw-r--r--print/hugelatex/Makefile35
-rw-r--r--print/hugelatex/files/texmf.cnf-add15
-rw-r--r--print/hugelatex/pkg-comment1
-rw-r--r--print/hugelatex/pkg-descr2
-rw-r--r--print/hugelatex/pkg-plist8
5 files changed, 61 insertions, 0 deletions
diff --git a/print/hugelatex/Makefile b/print/hugelatex/Makefile
new file mode 100644
index 000000000000..a9970919d270
--- /dev/null
+++ b/print/hugelatex/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: hugelatex
+# Date created: 7 September 2001
+# Whom: Murray Stokely <murray@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# $NetBSD: Makefile,v 1.3 2001/09/02 19:51:38 hubertf Exp $
+#
+
+PORTNAME= hugelatex
+PORTVERSION= 1.0
+CATEGORIES= print
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= murray@FreeBSD.org
+
+BUILD_DEPENDS= tex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+TEXMF_CNF= ${LOCALBASE}/share/texmf/web2c/texmf.cnf
+
+do-install:
+ ${CP} -p ${TEXMF_CNF} ${TEXMF_CNF}-before-hugelatex
+ ${CAT} ${FILESDIR}/texmf.cnf-add >>${TEXMF_CNF}
+ cd `dirname ${TEXMF_CNF}`; \
+ ${ECHO} "" | ${PREFIX}/bin/latex -ini -fmt=hugelatex -progname=hugelatex latex.ini || ${TRUE}; \
+ ${RM} -f texsys.aux
+ ${RM} -f ${PREFIX}/bin/hugelatex
+ ${LN} -s latex ${PREFIX}/bin/hugelatex
+ ${PREFIX}/bin/mktexlsr
+
+.include <bsd.port.mk>
diff --git a/print/hugelatex/files/texmf.cnf-add b/print/hugelatex/files/texmf.cnf-add
new file mode 100644
index 000000000000..a9dad313e528
--- /dev/null
+++ b/print/hugelatex/files/texmf.cnf-add
@@ -0,0 +1,15 @@
+
+% hugelatex settings
+% added by hugelatex package
+main_memory.hugelatex = 1100000
+param_size.hugelatex = 1500
+stack_size.hugelatex = 1500
+hash_extra.hugelatex = 15000
+string_vacancies.hugelatex = 45000
+pool_free.hugelatex = 47500
+nest_size.hugelatex = 500
+save_size.hugelatex = 5000
+pool_size.hugelatex = 500000
+max_strings.hugelatex = 55000
+font_mem_size.hugelatex= 400000
+
diff --git a/print/hugelatex/pkg-comment b/print/hugelatex/pkg-comment
new file mode 100644
index 000000000000..10e41fcfa7ac
--- /dev/null
+++ b/print/hugelatex/pkg-comment
@@ -0,0 +1 @@
+LaTeX format files with large limits
diff --git a/print/hugelatex/pkg-descr b/print/hugelatex/pkg-descr
new file mode 100644
index 000000000000..d56fed61538f
--- /dev/null
+++ b/print/hugelatex/pkg-descr
@@ -0,0 +1,2 @@
+LaTeX format files with large limits needed e.g. by jadetex
+to process files converted from SGML.
diff --git a/print/hugelatex/pkg-plist b/print/hugelatex/pkg-plist
new file mode 100644
index 000000000000..420457db0f1b
--- /dev/null
+++ b/print/hugelatex/pkg-plist
@@ -0,0 +1,8 @@
+@comment $NetBSD: PLIST,v 1.2 2000/11/27 22:59:46 hubertf Exp $
+bin/hugelatex
+share/texmf/web2c/hugelatex.fmt
+share/texmf/web2c/hugelatex.log
+@exec cp %D/share/texmf/web2c/texmf.cnf %D/share/texmf/web2c/texmf.cnf-before-hugelatex
+share/texmf/web2c/texmf.cnf
+@unexec mv %D/share/texmf/web2c/texmf.cnf-before-hugelatex %D/share/texmf/web2c/texmf.cnf
+@unexec %D/bin/mktexlsr