aboutsummaryrefslogtreecommitdiff
path: root/print/jabref
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-02-13 12:53:31 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-02-13 12:53:31 +0000
commit92b82b75fbcba4dca51afaf80ed2412c8e648f4d (patch)
tree9131819fbe8e765a11ab6197a48e00c412988b48 /print/jabref
parent1cbd0b6f1ca0d973561a39d8103e8daf7422f379 (diff)
downloadports-92b82b75fbcba4dca51afaf80ed2412c8e648f4d.tar.gz
ports-92b82b75fbcba4dca51afaf80ed2412c8e648f4d.zip
Notes
Diffstat (limited to 'print/jabref')
-rw-r--r--print/jabref/Makefile37
-rw-r--r--print/jabref/distinfo3
-rw-r--r--print/jabref/files/jabref.sh.in5
-rw-r--r--print/jabref/pkg-descr16
4 files changed, 61 insertions, 0 deletions
diff --git a/print/jabref/Makefile b/print/jabref/Makefile
new file mode 100644
index 000000000000..16829aa0b7d7
--- /dev/null
+++ b/print/jabref/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: jabref
+# Date created: 18 Jan 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+
+PORTNAME= jabref
+PORTVERSION= 2.0b2
+CATEGORIES= print java editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= JabRef-${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= #
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= A (BibTeX native) bibliographic reference manager
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+SUB_FILES= ${PORTNAME}.sh
+SUB_LIST= JARNAME=${DISTFILES}
+
+PLIST_FILES= %%DATADIR%%/${DISTFILES} \
+ bin/${PORTNAME}
+PLIST_DIRS= %%DATADIR%%
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/print/jabref/distinfo b/print/jabref/distinfo
new file mode 100644
index 000000000000..7dcc4c1a3e5f
--- /dev/null
+++ b/print/jabref/distinfo
@@ -0,0 +1,3 @@
+MD5 (JabRef-2.0b2.jar) = ab797d590977a82899a68e23ef5fde7b
+SHA256 (JabRef-2.0b2.jar) = 6cb88627e04450d76a8cb8cba6177eb945cf8d1c3555d8c1f387547ca402538c
+SIZE (JabRef-2.0b2.jar) = 3421803
diff --git a/print/jabref/files/jabref.sh.in b/print/jabref/files/jabref.sh.in
new file mode 100644
index 000000000000..9e61fd0d7fee
--- /dev/null
+++ b/print/jabref/files/jabref.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/%%JARNAME%%" "$@"
diff --git a/print/jabref/pkg-descr b/print/jabref/pkg-descr
new file mode 100644
index 000000000000..99fdd0cd4c12
--- /dev/null
+++ b/print/jabref/pkg-descr
@@ -0,0 +1,16 @@
+JabRef is an open source bibliography reference manager. The native file
+format used by JabRef is BibTeX, the standard LaTeX bibliography format.
+As such it can also be considered a BibTeX editor.
+
+JabRef runs on the Java VM (version 1.4.2 or greater).
+
+Some of its features:
+
+ o Search and fetch references from Medline/PubMed and CiteSeer
+ o Search, classify and sort entries in your BibTeX files
+ o import and export of references in various formats
+ o launch external viewers and insert citations into LyX and Kile
+ o automatically generate BibTeX keys
+ o customize (add your own) BibTeX fields
+
+WWW: http://jabref.sf.net