aboutsummaryrefslogtreecommitdiff
path: root/print/jadetex
diff options
context:
space:
mode:
authorNik Clayton <nik@FreeBSD.org>1998-12-08 21:08:28 +0000
committerNik Clayton <nik@FreeBSD.org>1998-12-08 21:08:28 +0000
commite366972e903d7c4790bd45fd9710715893bbdcde (patch)
treee55736456a77986cebc0d988707d4f3f4e8c0c92 /print/jadetex
parent207e0fe9be1ffdf98758be3702876e22d62ed48f (diff)
downloadports-e366972e903d7c4790bd45fd9710715893bbdcde.tar.gz
ports-e366972e903d7c4790bd45fd9710715893bbdcde.zip
Notes
Diffstat (limited to 'print/jadetex')
-rw-r--r--print/jadetex/Makefile42
-rw-r--r--print/jadetex/distinfo5
-rw-r--r--print/jadetex/pkg-comment1
-rw-r--r--print/jadetex/pkg-descr20
-rw-r--r--print/jadetex/pkg-message16
-rw-r--r--print/jadetex/pkg-plist6
6 files changed, 90 insertions, 0 deletions
diff --git a/print/jadetex/Makefile b/print/jadetex/Makefile
new file mode 100644
index 000000000000..b7d4e52bd860
--- /dev/null
+++ b/print/jadetex/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: jadetex
+# Version required: 2.3
+# Date created: 5 December 1998
+# Whom: Sean Kelly <kelly@plutotech.com>
+#
+# $Id$
+#
+# When jadetex-2.3 goes mainstream, it will replace jadetex-2.1
+# currently in the Comprehensive TeX Archive Network (CTAN). When
+# that happens, we ought to change MASTER_SITES to
+# MASTER_SITE_TEX_CTAN, and remove the DISTFILES, EXTRACT_CMD,
+# EXTRACT_SUFX, EXTRACT_AFTER_ARGS, and NO_WRKSUBDIR.
+#
+
+DISTNAME= jadetex
+CATEGORIES= print
+VERSION= 2.3
+PKGNAME= ${DISTNAME}-${VERSION}
+MAINTAINER= kelly@plutotech.com
+MASTER_SITES= http://tug.org/applications/jadetex/
+DISTFILES= Makefile.jadetex jadetex.dtx jadetex.ini jadetex.ins \
+ pdfjadetex.ini
+DIST_SUBDIR= jadetex
+NO_WRKSUBDIR= yes
+BUILD_DEPENDS= tex:${PORTSDIR}/print/teTeX-beta
+RUN_DEPENDS= tex:${PORTSDIR}/print/teTeX-beta
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= -fp
+EXTRACT_AFTER_ARGS= .
+EXTRACT_SUFX=
+
+post-extract:
+ @${ECHO} all: default > ${WRKSRC}/Makefile
+ @${SED} -e "s/huge//g" ${WRKSRC}/Makefile.jadetex >> ${WRKSRC}/Makefile
+
+do-install:
+ @(cd ${WRKSRC} && ${INSTALL_DATA} jadetex.fmt pdfjadetex.fmt `kpsewhich -expand-var '$$TEXMFMAIN'`/web2c && ${MKDIR} -m 555 `kpsewhich -expand-var '$$TEXMFMAIN'`/tex/jadetex && ${INSTALL_DATA} dsssl.def isoents.tex jadetex.ltx `kpsewhich -expand-var '$$TEXMFMAIN'`/tex/jadetex)
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/print/jadetex/distinfo b/print/jadetex/distinfo
new file mode 100644
index 000000000000..235219eaa637
--- /dev/null
+++ b/print/jadetex/distinfo
@@ -0,0 +1,5 @@
+MD5 (jadetex/Makefile.jadetex) = 83a0b78a797ee5d9b60ebb1de4bf8a15
+MD5 (jadetex/jadetex.dtx) = 23b12fa816191b86b1648cf17561ad1e
+MD5 (jadetex/jadetex.ini) = e7ce73c84a5005fe400583190b848ddb
+MD5 (jadetex/jadetex.ins) = e0f94e8e5f281e36fe4b78de6e23b48a
+MD5 (jadetex/pdfjadetex.ini) = a68ee493fdc86007923c593accb61e29
diff --git a/print/jadetex/pkg-comment b/print/jadetex/pkg-comment
new file mode 100644
index 000000000000..17ea70d0743c
--- /dev/null
+++ b/print/jadetex/pkg-comment
@@ -0,0 +1 @@
+JadeTeX is a TeX backend for Jade, for typesetting SGML documents.
diff --git a/print/jadetex/pkg-descr b/print/jadetex/pkg-descr
new file mode 100644
index 000000000000..9c75b2acab68
--- /dev/null
+++ b/print/jadetex/pkg-descr
@@ -0,0 +1,20 @@
+This is JadeTeX, a TeX backend for Jade.
+
+JadeTeX enables you to produce formatted output of documents written
+with the Standard Generalized Markup Language (SGML). JadeTeX uses
+tex to produce Device Independent (DVI) output; from there, you can
+produce high quality hardcopy. JadeTeX also uses pdftex to produce
+Adobe Portable Document Format (PDF) versions of your documents,
+complete with hyperlinks, and suitable for distribution on the World
+Wide Web and other media.
+
+To use JadeTex, run your SGML document, its Document Type Definition
+(DTD), and its Document Style Semantics and Specification Language
+(DSSSL) specification, through jade with the "-t tex" option. Then,
+to produce a DVI file, run
+
+ tex "&jadetex" <file>.tex
+
+To produce a PDF file, run
+
+ pdftex "&pdfjadetex" <file>.tex
diff --git a/print/jadetex/pkg-message b/print/jadetex/pkg-message
new file mode 100644
index 000000000000..4727809ad243
--- /dev/null
+++ b/print/jadetex/pkg-message
@@ -0,0 +1,16 @@
+JadeTeX uses quite a lot of TeX's resources. You may find it
+necessary to increase the size of some of TeX's resource pools by
+editing the file /usr/local/share/texmf/web2c/texmf.cnf with any text
+editor.
+
+For example, to typeset the FreeBSD Handbook with JadeTeX, change the
+following settings to the listed values:
+
+ hash_extra = 60000
+ pool_size = 1000000
+ max_strings = 70000
+ save_size = 10000
+
+If you change /usr/local/share/texmf/web2c/texmf.cnf, delete the word
+"original" on line 1 of the file. This will prevent future
+installations of TeX from overwriting changes you've made.
diff --git a/print/jadetex/pkg-plist b/print/jadetex/pkg-plist
new file mode 100644
index 000000000000..37883573abe9
--- /dev/null
+++ b/print/jadetex/pkg-plist
@@ -0,0 +1,6 @@
+share/texmf/tex/jadetex/dsssl.def
+share/texmf/tex/jadetex/isoents.tex
+share/texmf/tex/jadetex/jadetex.ltx
+share/texmf/web2c/jadetex.fmt
+share/texmf/web2c/pdfjadetex.fmt
+@dirrm share/texmf/tex/jadetex