aboutsummaryrefslogtreecommitdiff
path: root/print/kde4-print-manager
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-10-18 11:11:51 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-10-18 11:11:51 +0000
commitf0a6a10c0e903091a368549789588ee7d37f198a (patch)
tree6d3a6f70e7160afb6e552c0a2dd8e3cde11afa5f /print/kde4-print-manager
parentfb92e8597c613548e9eb9b4f86c73fd3caa80dc0 (diff)
Notes
Diffstat (limited to 'print/kde4-print-manager')
-rw-r--r--print/kde4-print-manager/Makefile7
-rw-r--r--print/kde4-print-manager/files/patch-libkcups-KCupsRequest.cpp10
2 files changed, 16 insertions, 1 deletions
diff --git a/print/kde4-print-manager/Makefile b/print/kde4-print-manager/Makefile
index 9d758127fb26..e4bedc2e16db 100644
--- a/print/kde4-print-manager/Makefile
+++ b/print/kde4-print-manager/Makefile
@@ -2,7 +2,7 @@
PORTNAME= print-manager
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -11,10 +11,15 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Printer manager for KDE 4
LIB_DEPENDS= libcups.so:print/cups
+RUN_DEPENDS= ${LOCALBASE}/share/cups/data/testprint:print/cups-filters
USES= cmake:outsource kde:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT4= designer network \
qmake_build moc_build uic_build rcc_build
+post-patch:
+ @${REINPLACE_CMD} 's,/usr/share/cups,${LOCALBASE}/share/cups,' \
+ ${WRKSRC}/libkcups/KCupsRequest.cpp
+
.include <bsd.port.mk>
diff --git a/print/kde4-print-manager/files/patch-libkcups-KCupsRequest.cpp b/print/kde4-print-manager/files/patch-libkcups-KCupsRequest.cpp
new file mode 100644
index 000000000000..142c49173d7a
--- /dev/null
+++ b/print/kde4-print-manager/files/patch-libkcups-KCupsRequest.cpp
@@ -0,0 +1,10 @@
+--- libkcups/KCupsRequest.cpp.orig 2014-10-16 19:09:36 UTC
++++ libkcups/KCupsRequest.cpp
+@@ -29,6 +29,7 @@
+ #include <QStringBuilder>
+
+ #include <cups/adminutil.h>
++#include <cups/ppd.h>
+
+ #define CUPS_DATADIR "/usr/share/cups"
+