aboutsummaryrefslogtreecommitdiff
path: root/print/kpdftool/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-05-11 17:26:35 +0000
committerXin LI <delphij@FreeBSD.org>2006-05-11 17:26:35 +0000
commit5496cfb272947f5b07e3cb13a581594920aba81b (patch)
tree0adf643dd5a8e3538bda3d37e83953f147ebb032 /print/kpdftool/Makefile
parent3fb5ddd6926e5e435a9218f23685ca01b091fc90 (diff)
Notes
Diffstat (limited to 'print/kpdftool/Makefile')
-rw-r--r--print/kpdftool/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
new file mode 100644
index 000000000000..c64dc224f3b7
--- /dev/null
+++ b/print/kpdftool/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: kpdftool
+# Date created: 04 May 2006
+# Whom: Yuan, Jue <yuanjue@yuanjue.net>
+# $FreeBSD$
+#
+
+PORTNAME= kpdftool
+PORTVERSION= 0.22
+CATEGORIES= print kde
+MASTER_SITES= http://www.yuanjue.net/download/
+
+MAINTAINER= yuanjue@yuanjue.net
+COMMENT= Tool to ease your PDF related work
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+
+USE_GMAKE= yes
+USE_QT_VER= 3
+CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+MAKE_ARGS+= QTDIR=${X11BASE}
+
+do-configure:
+ cd ${WRKSRC}; \
+ ${LOCALBASE}/bin/qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro;
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+PLIST_FILES= bin/kpdftool
+
+.include <bsd.port.mk>