aboutsummaryrefslogtreecommitdiff
path: root/print/latex-keystroke/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-24 18:33:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-24 18:33:20 +0000
commit7c3f4274095eba5ffe0e2c9f599912d182183851 (patch)
treefe97a73bc254d37fc473bd00f57c289d5aedd94a /print/latex-keystroke/Makefile
parentb091501256db06312d5f6e5e6862b9dbb0a32b55 (diff)
Notes
Diffstat (limited to 'print/latex-keystroke/Makefile')
-rw-r--r--print/latex-keystroke/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/print/latex-keystroke/Makefile b/print/latex-keystroke/Makefile
new file mode 100644
index 000000000000..0b63efd51f3a
--- /dev/null
+++ b/print/latex-keystroke/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: latex-keystroke
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-keystroke
+PORTVERSION= 1.0.20001109
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/keystroke
+DISTFILES= ${DOC_FILES} ${CLASS_FILES}
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package for the graphical representation of the keys
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= YES
+PLIST_SUB= TEXMF=${TEXMF} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMF= share/texmf
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMF}/tex/latex/${PORTNAME:S/^latex-//}
+
+DOC_FILES= README
+
+CLASS_FILES+= key-test.pdf
+CLASS_FILES+= key-test.tex
+CLASS_FILES+= keystroke.sty
+CLASS_FILES+= keystroke_left.eps
+CLASS_FILES+= keystroke_left.pdf
+CLASS_FILES+= keystroke_middle.eps
+CLASS_FILES+= keystroke_middle.pdf
+CLASS_FILES+= keystroke_right.eps
+CLASS_FILES+= keystroke_right.pdf
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>