aboutsummaryrefslogtreecommitdiff
path: root/print/latex-pgf/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-03 21:38:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-03 21:38:07 +0000
commit3da751f900c20e8e2d5ded2a53d77c550c5ae380 (patch)
treeec68fc528442e8a860e3472804d08c49e67b9870 /print/latex-pgf/Makefile
parentda0b46c8a15b7c47075431ab98453820aa92b688 (diff)
downloadports-3da751f900c20e8e2d5ded2a53d77c550c5ae380.tar.gz
ports-3da751f900c20e8e2d5ded2a53d77c550c5ae380.zip
Notes
Diffstat (limited to 'print/latex-pgf/Makefile')
-rw-r--r--print/latex-pgf/Makefile46
1 files changed, 17 insertions, 29 deletions
diff --git a/print/latex-pgf/Makefile b/print/latex-pgf/Makefile
index 5d1a12c54fcf..20879080fb4e 100644
--- a/print/latex-pgf/Makefile
+++ b/print/latex-pgf/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= latex-pgf
-PORTVERSION= 0.50
+PORTVERSION= 0.60
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= latex-beamer
@@ -14,41 +14,29 @@ DISTNAME= ${PORTNAME:S/^latex-//}-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= A LaTeX package for TeX Portable Graphic Format
-BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
-RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
NO_BUILD= YES
-PLIST_SUB= TEXMF=${TEXMF} MKTEXLSR=${MKTEXLSR}
-PLIST_SUB+= CLASSDIR=${CLASSDIR}
+PLIST_SUB= MKTEXLSR=${MKTEXLSR} CLASSDIR=${CLASSDIR}
-TEXMF= share/texmf
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
-CLASSDIR= ${TEXMF}/tex/latex/${PORTNAME:S/^latex-//}
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
-CLASS_FILES= pgf.sty
-CLASS_FILES+= pgfarrows.sty
-CLASS_FILES+= pgfautomata.sty
-CLASS_FILES+= pgfheaps.sty
-CLASS_FILES+= pgfnodes.sty
-CLASS_FILES+= pgfshade.sty
-CLASS_FILES+= xxcolor.sty
+CLASS_FILES= pgf.sty pgfarrows.sty pgfautomata.sty pgfheaps.sty \
+ pgfnodes.sty pgfshade.sty xxcolor.sty
-DOC_FILES= AUTHORS
-DOC_FILES+= ChangeLog
-DOC_FILES+= FILES
-DOC_FILES+= INSTALL
-DOC_FILES+= README
-DOC_FILES+= TODO
-DOC_FILES+= apple.jpg
-DOC_FILES+= apple.mask.jpg
-DOC_FILES+= pgfuserguide.pdf
-DOC_FILES+= pgfuserguide.tex
-DOC_FILES+= tu-logo.25.eps
-DOC_FILES+= tu-logo.25.jpg
-DOC_FILES+= tu-logo.eps
-DOC_FILES+= tu-logo.jpg
-DOC_FILES+= tu-logo.mask.jpg
+DOC_FILES= AUTHORS ChangeLog FILES INSTALL README TODO \
+ apple.jpg apple.mask.jpg \
+ pgfuserguide.pdf pgfuserguide.tex \
+ tu-logo.25.eps tu-logo.25.jpg \
+ tu-logo.eps tu-logo.jpg \
+ tu-logo.mask.jpg \
do-install:
${MKDIR} ${PREFIX}/${CLASSDIR}