aboutsummaryrefslogtreecommitdiff
path: root/print/latex-subfloat
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-29 10:48:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-29 10:48:17 +0000
commitf86be133febceafcfa1d7cec4169b37d5bb16b35 (patch)
treeee59ea4c1d69476bc33a49752d535368467b285c /print/latex-subfloat
parentedaecc1104469980a5af0ce203ec382156899997 (diff)
downloadports-f86be133febceafcfa1d7cec4169b37d5bb16b35.tar.gz
ports-f86be133febceafcfa1d7cec4169b37d5bb16b35.zip
Notes
Diffstat (limited to 'print/latex-subfloat')
-rw-r--r--print/latex-subfloat/Makefile60
-rw-r--r--print/latex-subfloat/distinfo7
-rw-r--r--print/latex-subfloat/pkg-descr6
-rw-r--r--print/latex-subfloat/pkg-plist12
4 files changed, 85 insertions, 0 deletions
diff --git a/print/latex-subfloat/Makefile b/print/latex-subfloat/Makefile
new file mode 100644
index 000000000000..0594e6c0946f
--- /dev/null
+++ b/print/latex-subfloat/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: latex-subfloat
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-subfloat
+PORTVERSION= 2.14.20030821
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/subfloat
+DISTFILES= Makefile subfloat.dtx subfloat.ins ${DOC_FILES}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package that enables subnumbering of different floats
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/tex
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= subfloat.dtx
+CLASS_FILES+= subfloat.sty
+CLASS_FILES+= subfloat.ins
+
+DOC_FILES= README
+DOC_FILES+= ChangeLog
+DOC_FILES+= subfloat.dvi
+DOC_FILES+= subfloat.xml
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${TEX_BIN} subfloat.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ @${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-subfloat/distinfo b/print/latex-subfloat/distinfo
new file mode 100644
index 000000000000..b228428a1a4d
--- /dev/null
+++ b/print/latex-subfloat/distinfo
@@ -0,0 +1,7 @@
+MD5 (latex-subfloat/Makefile) = d583e85d6d11dc8dcba05ee4a4f847a6
+MD5 (latex-subfloat/subfloat.dtx) = 5480bc25b3fc716da8d95ddeafc3c35f
+MD5 (latex-subfloat/subfloat.ins) = 98b93e026734ccd997d4994e92099a2e
+MD5 (latex-subfloat/README) = ce3f9f252b3e419d30740708b9ab82e9
+MD5 (latex-subfloat/ChangeLog) = 197de46e6e3a85527ca0166b6ae7e66c
+MD5 (latex-subfloat/subfloat.dvi) = db641989b4e6d0a591c3519f4c318049
+MD5 (latex-subfloat/subfloat.xml) = c832e5d02198274d9b4077efda930264
diff --git a/print/latex-subfloat/pkg-descr b/print/latex-subfloat/pkg-descr
new file mode 100644
index 000000000000..9a29ac51f4c5
--- /dev/null
+++ b/print/latex-subfloat/pkg-descr
@@ -0,0 +1,6 @@
+subfloat.sty -- subnumbering for figures and tables
+
+This package enables subnumbering of different floats (figures and
+tables) simular to the subequations-environment of the amsmath
+package. It does not the same as the subfigure package which
+generates subfigures within one normal figure.
diff --git a/print/latex-subfloat/pkg-plist b/print/latex-subfloat/pkg-plist
new file mode 100644
index 000000000000..a1fc468e95ee
--- /dev/null
+++ b/print/latex-subfloat/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/subfloat.dvi
+%%PORTDOCS%%%%DOCSDIR%%/subfloat.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/subfloat.dtx
+%%CLASSDIR%%/subfloat.ins
+%%CLASSDIR%%/subfloat.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%