aboutsummaryrefslogtreecommitdiff
path: root/print/latex-supertabular
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-11-14 13:53:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-11-14 13:53:36 +0000
commit1b8b768f5e59d8db8d77e7c623a588c598140e54 (patch)
tree6a219a31a0cc71135604615b6d6a6b7984e82f36 /print/latex-supertabular
parentbacc21794ed55d094f43e1775ebdc6df83b1b853 (diff)
downloadports-1b8b768f5e59d8db8d77e7c623a588c598140e54.tar.gz
ports-1b8b768f5e59d8db8d77e7c623a588c598140e54.zip
Notes
Diffstat (limited to 'print/latex-supertabular')
-rw-r--r--print/latex-supertabular/Makefile53
-rw-r--r--print/latex-supertabular/distinfo18
-rw-r--r--print/latex-supertabular/pkg-descr6
-rw-r--r--print/latex-supertabular/pkg-plist10
4 files changed, 87 insertions, 0 deletions
diff --git a/print/latex-supertabular/Makefile b/print/latex-supertabular/Makefile
new file mode 100644
index 000000000000..2e10bda4658b
--- /dev/null
+++ b/print/latex-supertabular/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: latex-supertabular
+# Date created: Aug 20 2008
+# Whom: Jorge Niedbalski <niedbalski@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latex-supertabular
+PORTVERSION= 1
+CATEGORIES= print
+MASTER_SITES= ftp://tug.ctan.org/pub/tex-archive/macros/latex/contrib/supertabular/
+DISTFILES= supertabular.dtx supertabular.ins ${DOC_FILES}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= niedbalski@gmail.com
+COMMENT= A LaTeX package for a tabular that spans multiple pages
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR} \
+ CLASSDIR=${CLASSDIR}
+USE_GMAKE= yes
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/latex
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+CLASS_FILES= supertabular.dtx supertabular.sty supertabular.ins
+DOC_FILES= README MANIFEST CATALOG supertabular.pdf
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${TEX_BIN} supertabular.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ @${MKTEXLSR} ${TEXMFLOCAL}
+
+.include <bsd.port.mk>
diff --git a/print/latex-supertabular/distinfo b/print/latex-supertabular/distinfo
new file mode 100644
index 000000000000..7ab8598d13f2
--- /dev/null
+++ b/print/latex-supertabular/distinfo
@@ -0,0 +1,18 @@
+MD5 (latex-supertabular/supertabular.dtx) = 6b487ac78f1eaec3a5e5175162af2edf
+SHA256 (latex-supertabular/supertabular.dtx) = 85abd2960d6d28a52d1e231a63b12704dd63f4b9c3a797b982d4fa4f70af8f2c
+SIZE (latex-supertabular/supertabular.dtx) = 56087
+MD5 (latex-supertabular/supertabular.ins) = 176faaee64755afea3520c7e347c3915
+SHA256 (latex-supertabular/supertabular.ins) = 6212a73411b35dde7c3d1f0d35245d96e8547aaac63a9737ed5ca77f21271b8a
+SIZE (latex-supertabular/supertabular.ins) = 2507
+MD5 (latex-supertabular/README) = e2aa33bf732e2930e32c58c1a7b3a998
+SHA256 (latex-supertabular/README) = 9a9239e7e70fd8c60404945c9de191c07fa59a4fdb23866b0577a1ea53f2d390
+SIZE (latex-supertabular/README) = 960
+MD5 (latex-supertabular/MANIFEST) = 624bb143d179009770bfb82f9e99e8fe
+SHA256 (latex-supertabular/MANIFEST) = d690ec63407a3d660690af247fe365b14d83215dc075575c4d198d003b966324
+SIZE (latex-supertabular/MANIFEST) = 453
+MD5 (latex-supertabular/CATALOG) = 28351044d470aed16767de30c01dbb1b
+SHA256 (latex-supertabular/CATALOG) = fa6d66f49b93108cf5311757d960083acfd54597ad30c1ef86007f4efc7a492c
+SIZE (latex-supertabular/CATALOG) = 857
+MD5 (latex-supertabular/supertabular.pdf) = d97413de45073971bf5532d4c9c542d3
+SHA256 (latex-supertabular/supertabular.pdf) = e098f44149ef14f6e7fc324cfc95523c41ec0f2f674fdbb419a53d4f7aab5285
+SIZE (latex-supertabular/supertabular.pdf) = 159124
diff --git a/print/latex-supertabular/pkg-descr b/print/latex-supertabular/pkg-descr
new file mode 100644
index 000000000000..f5b4f21c73ac
--- /dev/null
+++ b/print/latex-supertabular/pkg-descr
@@ -0,0 +1,6 @@
+The supertabular bundle defines the supertabular and supertabular*
+environments. They make it possible to have a tabular that spans multiple
+pages. Each page is its own tabular environment, thus the various parts may
+have different widths.
+
+WWW: http://www.ctan.org/tex-archive/macros/latex/contrib/supertabular/
diff --git a/print/latex-supertabular/pkg-plist b/print/latex-supertabular/pkg-plist
new file mode 100644
index 000000000000..7984b7217dfa
--- /dev/null
+++ b/print/latex-supertabular/pkg-plist
@@ -0,0 +1,10 @@
+%%PORTDOCS%%%%DOCSDIR%%/CATALOG
+%%PORTDOCS%%%%DOCSDIR%%/MANIFEST
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/supertabular.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/supertabular.dtx
+%%CLASSDIR%%/supertabular.ins
+%%CLASSDIR%%/supertabular.sty
+@exec %%MKTEXLSR%% %D/%%TEXMFLOCAL%%
+@unexec %%MKTEXLSR%% %D/%%TEXMFLOCAL%%