aboutsummaryrefslogtreecommitdiff
path: root/print/libgnomeprint/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 16:57:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 16:57:19 +0000
commit273855ca01349031918fab26918c9af911385c5d (patch)
tree3bdd249396cf83eec3ac1feed96bc711269b12e4 /print/libgnomeprint/Makefile
parent374106e59a30e6b40565935b07e7c870f7b809fb (diff)
downloadports-273855ca01349031918fab26918c9af911385c5d.tar.gz
ports-273855ca01349031918fab26918c9af911385c5d.zip
Notes
Diffstat (limited to 'print/libgnomeprint/Makefile')
-rw-r--r--print/libgnomeprint/Makefile33
1 files changed, 16 insertions, 17 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 5f661689b6de..13da9d1d6e25 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -1,42 +1,41 @@
-# New ports collection makefile for: gnomeprint
+# New ports collection makefile for: libgnomeprint
# Date created: 15 Jan 1999
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= gnomeprint
-PORTVERSION= 0.35
+PORTNAME= libgnomeprint
+PORTVERSION= 1.111.0
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/gnome-print
-DISTNAME= gnome-print-${PORTVERSION}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta2
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
-
-PLIST_SUB= VERSION=${PORTVERSION}
+LIB_DEPENDS= bonobo-2.0:${PORTSDIR}/devel/libbonobo \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2 \
+ gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_PERL5= yes
-USE_GNOMECTRL= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/usr/X11R6/share/gnome2 \
+ --datadir=/usr/X11R6/share/gnome2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name '*.[ch]' | xargs ${PERL} -pi -e \
+ 's|<malloc\.h>|<stdlib.h>|'
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-post-install:
- @${TOUCH} ${PREFIX}/etc/gnome/fonts/gnome-print-x11.fontmap
+ 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>