aboutsummaryrefslogtreecommitdiff
path: root/print/libgnomeprint/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /print/libgnomeprint/Makefile
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadports-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
ports-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Notes
Diffstat (limited to 'print/libgnomeprint/Makefile')
-rw-r--r--print/libgnomeprint/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 6f9539942905..02ba62a60ba2 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -18,8 +18,8 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ popt:${PORTSDIR}/devel/popt
USES= bison pathfix
USE_GMAKE= yes
@@ -34,13 +34,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION=${PORTVERSION} \
LIBVERSION=2.2
-OPTIONS= CUPS "Enable CUPS support" on
+OPTIONS_DEFINE= CUPS
+OPTIONS_DEFAULT=CUPS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_CUPS) && !defined(WITHOUT_CUPS)
+.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+= --with-cups
-LIB_DEPENDS+= gnomecups-1.0:${PORTSDIR}/print/libgnomecups
+LIB_DEPENDS+= gnomecups-1:${PORTSDIR}/print/libgnomecups
PLIST_SUB+= CUPS:=""
.else
CONFIGURE_ARGS+= --without-cups
@@ -57,6 +58,6 @@ post-install:
@${MKDIR} ${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts
@${TOUCH} ${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif