aboutsummaryrefslogtreecommitdiff
path: root/print/libgnomeprint
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 10:00:58 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 10:00:58 +0000
commit3b42546213296fba4069ebf7a9233b252abd8051 (patch)
treee6936ed00f11ba1059d079060a0e8410207e7a55 /print/libgnomeprint
parent7e5e9a7b8e0bf3f1b7218623b628e1938e93c4a7 (diff)
downloadports-3b42546213296fba4069ebf7a9233b252abd8051.tar.gz
ports-3b42546213296fba4069ebf7a9233b252abd8051.zip
Notes
Diffstat (limited to 'print/libgnomeprint')
-rw-r--r--print/libgnomeprint/Makefile2
-rw-r--r--print/libgnomeprint/files/patch-configure17
-rw-r--r--print/libgnomeprint/files/patch-ltmain.sh45
3 files changed, 15 insertions, 49 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 364940c90388..536f7f7c52b6 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome2 \
--datadir=${PREFIX}/share/gnome2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/print/libgnomeprint/files/patch-configure b/print/libgnomeprint/files/patch-configure
index 92732781f26e..0dc458067916 100644
--- a/print/libgnomeprint/files/patch-configure
+++ b/print/libgnomeprint/files/patch-configure
@@ -1,6 +1,17 @@
---- configure.orig Thu Apr 4 14:55:34 2002
-+++ configure Thu Apr 4 14:55:48 2002
-@@ -7180,7 +7180,7 @@
+
+$FreeBSD$
+
+--- configure.orig Fri Apr 26 12:49:10 2002
++++ configure Fri Apr 26 12:49:40 2002
+@@ -5591,6 +5591,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -7180,7 +7181,7 @@
INSTALL_FONTS_TRUE='#'
INSTALL_FONTS_FALSE=
fi
diff --git a/print/libgnomeprint/files/patch-ltmain.sh b/print/libgnomeprint/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/print/libgnomeprint/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"