aboutsummaryrefslogtreecommitdiff
path: root/print/libharu/files
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-14 15:09:30 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-14 15:09:30 +0000
commit4f800583b99d81a17d3b6e32212a7a8d25d8c1af (patch)
tree9d43e456f721cdf005271c60bfe5c0dca77fc749 /print/libharu/files
parentb965e1be9af4fa81233a511519083eb99d6552af (diff)
downloadports-4f800583b99d81a17d3b6e32212a7a8d25d8c1af.tar.gz
ports-4f800583b99d81a17d3b6e32212a7a8d25d8c1af.zip
Notes
Diffstat (limited to 'print/libharu/files')
-rw-r--r--print/libharu/files/patch-demo_CMakeLists.txt21
-rw-r--r--print/libharu/files/patch-hpdf_image_png.c10
2 files changed, 21 insertions, 10 deletions
diff --git a/print/libharu/files/patch-demo_CMakeLists.txt b/print/libharu/files/patch-demo_CMakeLists.txt
new file mode 100644
index 000000000000..012ebc791b10
--- /dev/null
+++ b/print/libharu/files/patch-demo_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- demo/CMakeLists.txt.orig 2013-11-18 14:51:59.000000000 +0100
++++ demo/CMakeLists.txt 2013-11-18 14:52:21.000000000 +0100
+@@ -86,15 +86,15 @@
+ # =======================================================================
+ install(
+ TARGETS ${demos_NAMES} ${demos_with_grid_NAMES} grid_sheet
+- DESTINATION demo
++ DESTINATION ${EXAMPLESDIR}
+ )
+ foreach(demo ${demos_NAMES} ${demos_with_grid_NAMES} grid_sheet)
+- install(FILES ${demo}.c DESTINATION demo)
++ install(FILES ${demo}.c DESTINATION ${EXAMPLESDIR})
+ endforeach(demo)
+
+ # install demo files
+ install(
+ DIRECTORY images mbtext pngsuite rawimage ttfont type1
+- DESTINATION demo
++ DESTINATION ${EXAMPLESDIR}
+ )
+ endif(LIBHPDF_EXAMPLES)
diff --git a/print/libharu/files/patch-hpdf_image_png.c b/print/libharu/files/patch-hpdf_image_png.c
deleted file mode 100644
index 57f59185f63d..000000000000
--- a/print/libharu/files/patch-hpdf_image_png.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/hpdf_image_png.c.orig 2010-02-08 10:27:51.000000000 +0100
-+++ src/hpdf_image_png.c 2012-05-06 06:53:50.000000000 +0200
-@@ -21,6 +21,7 @@
-
- #ifndef LIBHPDF_HAVE_NOPNGLIB
- #include <png.h>
-+#include <pngpriv.h>
-
- static void
- PngErrorFunc (png_structp png_ptr,