aboutsummaryrefslogtreecommitdiff
path: root/print/libharu
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /print/libharu
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'print/libharu')
-rw-r--r--print/libharu/Makefile5
-rw-r--r--print/libharu/files/patch-hpdf_image_png.c10
2 files changed, 13 insertions, 2 deletions
diff --git a/print/libharu/Makefile b/print/libharu/Makefile
index 3c36b1a886a5..5e1b0b96e20c 100644
--- a/print/libharu/Makefile
+++ b/print/libharu/Makefile
@@ -8,17 +8,18 @@
PORTNAME= libharu
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://libharu.org/files/
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Haru Free PDF Library
-LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-png=${LOCALBASE}
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
USE_LDCONFIG= yes
SOVERSION= 2
diff --git a/print/libharu/files/patch-hpdf_image_png.c b/print/libharu/files/patch-hpdf_image_png.c
new file mode 100644
index 000000000000..57f59185f63d
--- /dev/null
+++ b/print/libharu/files/patch-hpdf_image_png.c
@@ -0,0 +1,10 @@
+--- src/hpdf_image_png.c.orig 2010-02-08 10:27:51.000000000 +0100
++++ src/hpdf_image_png.c 2012-05-06 06:53:50.000000000 +0200
+@@ -21,6 +21,7 @@
+
+ #ifndef LIBHPDF_HAVE_NOPNGLIB
+ #include <png.h>
++#include <pngpriv.h>
+
+ static void
+ PngErrorFunc (png_structp png_ptr,