aboutsummaryrefslogtreecommitdiff
path: root/print/libharu
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-12 15:29:37 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-12 15:29:37 +0000
commitcdb8256f1be073ee580443f055cea42dfa4f0a8a (patch)
tree88f5fc59ca92cb0cc696d418e8dff349c265467f /print/libharu
parentdf5a2ca332127a415e6435541bf0ed6a3add9e96 (diff)
downloadports-cdb8256f1be073ee580443f055cea42dfa4f0a8a.tar.gz
ports-cdb8256f1be073ee580443f055cea42dfa4f0a8a.zip
Notes
Diffstat (limited to 'print/libharu')
-rw-r--r--print/libharu/Makefile3
-rw-r--r--print/libharu/files/patch-demo_CMakeLists.txt10
2 files changed, 10 insertions, 3 deletions
diff --git a/print/libharu/Makefile b/print/libharu/Makefile
index 56d45da4c4c5..bfce1f53ca0a 100644
--- a/print/libharu/Makefile
+++ b/print/libharu/Makefile
@@ -33,7 +33,6 @@ CMAKE_ARGS+= -DLIBHPDF_EXAMPLES:BOOL=ON \
.endif
post-install:
- ${LN} -s ${PREFIX}/lib/libhpdf.so \
- ${STAGEDIR}${PREFIX}/lib/libhpdf.so.${SOVERSION}
+ ${LN} -s libhpdf.so ${STAGEDIR}${PREFIX}/lib/libhpdf.so.${SOVERSION}
.include <bsd.port.mk>
diff --git a/print/libharu/files/patch-demo_CMakeLists.txt b/print/libharu/files/patch-demo_CMakeLists.txt
index 012ebc791b10..7a1e3f425763 100644
--- a/print/libharu/files/patch-demo_CMakeLists.txt
+++ b/print/libharu/files/patch-demo_CMakeLists.txt
@@ -1,6 +1,14 @@
--- demo/CMakeLists.txt.orig 2013-11-18 14:51:59.000000000 +0100
+++ demo/CMakeLists.txt 2013-11-18 14:52:21.000000000 +0100
-@@ -86,15 +86,15 @@
+@@ -75,6 +75,7 @@
+ set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
+ endif(DEMO_C_FLAGS)
+ endforeach(demo)
++ target_link_libraries(text_demo2 m)
+
+ # the grid_sheet demo needs extra defines
+ add_executable(grid_sheet grid_sheet.c)
+@@ -86,15 +87,15 @@
# =======================================================================
install(
TARGETS ${demos_NAMES} ${demos_with_grid_NAMES} grid_sheet