aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-12-23 10:59:47 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-12-23 10:59:47 +0000
commit640b1f96bcb68f666161c6385f4d8751ea056197 (patch)
treed6500829efdb7ebd7669aea9e7dae7b895cc2633 /print/lilypond/Makefile
parent012b1db72782b3a1eaaa768bbb0db9268b2d9d9b (diff)
downloadports-640b1f96bcb68f666161c6385f4d8751ea056197.tar.gz
ports-640b1f96bcb68f666161c6385f4d8751ea056197.zip
Notes
Diffstat (limited to 'print/lilypond/Makefile')
-rw-r--r--print/lilypond/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index f7172e28762e..d5c477628c23 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= lilypond
-PORTVERSION= 2.13.6
+PORTVERSION= 2.13.9
CATEGORIES= print audio
MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v2.13/:src \
${MASTER_SITE_LOCAL}/gahr/:fonts \
@@ -42,11 +42,9 @@ OPTIONS= WEBDOCS "Include web documentation" off
MAN1= lilymidi.1 lilypond-book.1 lilypond-invoke-editor.1 \
lilypond.1 lilysong.1 convert-ly.1 abc2ly.1 etf2ly.1 \
midi2ly.1 musicxml2ly.1
-
INFO= lilypond-changes lilypond-contributor lilypond-essay \
- lilypond-extending lilypond-general lilypond-internals \
- lilypond-learning lilypond-notation lilypond-usage \
- music-glossary
+ lilypond-extending lilypond-internals lilypond-learning \
+ lilypond-notation lilypond-usage lilypond-web music-glossary
USE_AUTOTOOLS= autoconf:262
USE_BISON= build
@@ -57,7 +55,7 @@ USE_GNOME= pango
INSTALLS_OMF= yes
MAKEFILE= GNUmakefile
ALL_TARGET= all
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" MAKEINFO="${LOCALBASE}/bin/makeinfo"
+CONFIGURE_ENV+= MAKEINFO="${LOCALBASE}/bin/makeinfo"
NOCCACHE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
@@ -85,18 +83,22 @@ post-patch:
${WRKSRC}/configure
${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
${WRKSRC}/lily/include/includable-lexer.hh
-# Documentation in Spanish does not build...
- ${REINPLACE_CMD} -e '70s|es, ||' ${WRKSRC}/python/langdefs.py
${REINPLACE_CMD} -e 's|sed|gsed|g' ${WRKSRC}/Documentation/GNUmakefile
.if defined(WITHOUT_NLS)
${REINPLACE_CMD} -e '17,21d' ${WRKSRC}/po/GNUmakefile
.endif
+pre-install:
+.if exists(${PREFIX}/info/dir)
+ ${REINPLACE_CMD} -i '' -e '/LilyPond/d' ${PREFIX}/info/dir
+.endif
+
post-install:
@${LN} -s ${DATADIR}/${PORTVERSION} ${DATADIR}/current
.if !defined(NOPORTDOCS) && defined(WITH_WEBDOCS)
@echo "Installing documentation... this takes a while..."
- @(cd ${WRKSRC}/out-www/offline-root && ${COPYTREE_SHARE} \* ${DOCSDIR})
+ cd ${WRKSRC} && ${GMAKE} install-doc
+# @(cd ${WRKSRC}/out-www/offline-root && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
.include <bsd.port.post.mk>