aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-05 03:45:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-05 03:45:48 +0000
commit8af80ff87e55097282fa2415c3064ff0ad0fa808 (patch)
tree867c8e331887d3860fe91d62f044b6e2a56a6145 /print/lilypond
parent80c06677042ea3a4fbab231ca25afa94820fef67 (diff)
downloadports-8af80ff87e55097282fa2415c3064ff0ad0fa808.tar.gz
ports-8af80ff87e55097282fa2415c3064ff0ad0fa808.zip
Notes
Diffstat (limited to 'print/lilypond')
-rw-r--r--print/lilypond/Makefile15
-rw-r--r--print/lilypond/distinfo3
-rw-r--r--print/lilypond/files/patch-mf:GNUMakefile2
3 files changed, 9 insertions, 11 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index a45a302f6712..cc6ed035e3b2 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -10,7 +10,11 @@
PORTNAME= lilypond
PORTVERSION= 2.2.2
CATEGORIES= print audio
-MASTER_SITES= http://lilypond.org/download/v2.2/
+MASTER_SITES= http://lilypond.org/download/v2.2/:src \
+ http://distfiles.master.finkmirrors.net/:rpm
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:src \
+ ${PORTNAME}-${PORTVERSION}-1.i386.rpm:rpm
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The GNU music typesetter
@@ -25,8 +29,6 @@ MAN1= abc2ly.1 etf2ly.1 midi2ly.1 mup2ly.1 lilypond.1 musedata2ly.1 \
INFO= lilypond lilypond-internals \
music-glossary
-CONFLICTS= lilypond-2.*
-
#INSTALLS_SHLIB not needed for phyton library midi.so
GNU_CONFIGURE= yes
@@ -44,7 +46,6 @@ CONFIGURE_ENV+= "CPPFLAGS=${CPPFLAGS}"
.if defined(WITH_SELFBUILT_FONTS)
BUILD_DEPENDS+= mftrace:${PORTSDIR}/print/mftrace
.else
-BUILD_DEPENDS+= wget:${PORTSDIR}/ftp/wget
BUILD_DEPENDS+= rpm2cpio:${PORTSDIR}/archivers/rpm
.endif
@@ -74,9 +75,6 @@ PLIST_SUB+= CONDITIONAL=""
.endif
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-#IGNORING portlint 2.5.0 WARN: possible direct use of command "install" found at line 64. use ${INSTALL_foobaa} instead.
-INSTALL_INFO?= install-info
-
pre-configure:
${SED} -e "s=%%LOCALBASE%%=${LOCALBASE}=g;s=%%DATADIRVERSION%%=${DATADIR}/${PORTVERSION}=g" \
< ${FILESDIR}/pkg-install.in \
@@ -104,9 +102,6 @@ post-install:
--exclude=dummy.dep --exclude=CVS --exclude=GNUmakefile . \
| ${TAR} -xf - -C ${DOCSDIR}
-.for ii in ${INFO}
- - ${INSTALL_INFO} ${PREFIX}/info/${ii}.info ${PREFIX}/info/dir
-.endfor
.endif
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/print/lilypond/distinfo b/print/lilypond/distinfo
index 14f7e5f7472c..db9a2a5661ad 100644
--- a/print/lilypond/distinfo
+++ b/print/lilypond/distinfo
@@ -1,3 +1,6 @@
MD5 (lilypond-2.2.2.tar.gz) = 1f9ed6b5a80533ce6c960c889fa51226
SHA256 (lilypond-2.2.2.tar.gz) = 0b65cdb5e303a90617ccc2b35f5ff3a27e462c1ed5f8f7a0a1973fa1a7cb2381
SIZE (lilypond-2.2.2.tar.gz) = 1900426
+MD5 (lilypond-2.2.2-1.i386.rpm) = 00389bd6b909d7a2023d29013e8f2338
+SHA256 (lilypond-2.2.2-1.i386.rpm) = 079d2e3c3a7aa56b156c890fa636af20a88a4bbc2935ea6378277973bd532cf4
+SIZE (lilypond-2.2.2-1.i386.rpm) = 4264723
diff --git a/print/lilypond/files/patch-mf:GNUMakefile b/print/lilypond/files/patch-mf:GNUMakefile
index d2f6f764d072..be812ad1539d 100644
--- a/print/lilypond/files/patch-mf:GNUMakefile
+++ b/print/lilypond/files/patch-mf:GNUMakefile
@@ -30,7 +30,7 @@
redhat-package=lilypond-$(TOPLEVEL_VERSION)-1.i386.rpm
$(outdir)/$(redhat-package):
- wget --passive-ftp -P $(outdir) http://lilypond.org/download/binaries/RedHat-9/$(redhat-package)
-+ wget --passive-ftp -P $(outdir) http://www.lilypond.org/ftp/binaries/Fedora-1/$(redhat-package)
++ cp ${DISTDIR}/$(redhat-package) $(outdir)
+ #wget --passive-ftp -P $(outdir) http://lilypond.org/download/binaries/RedHat-9/$(redhat-package)
get-rpm-pfa: $(outdir)/$(redhat-package)