aboutsummaryrefslogtreecommitdiff
path: root/print/lyx-devel/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-07-14 05:53:58 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-07-14 05:53:58 +0000
commit8d66f83145e3af14c139104ae6a91b811a8acc1c (patch)
tree796b072c717e66f57f84e28dad91e5aad1cb7956 /print/lyx-devel/Makefile
parent2ac12a3a6d4bc6c056a98932069bb8caa077aa0b (diff)
downloadports-8d66f83145e3af14c139104ae6a91b811a8acc1c.tar.gz
ports-8d66f83145e3af14c139104ae6a91b811a8acc1c.zip
Notes
Diffstat (limited to 'print/lyx-devel/Makefile')
-rw-r--r--print/lyx-devel/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/print/lyx-devel/Makefile b/print/lyx-devel/Makefile
index ecd5ceab2ef6..8ccac45d5e2a 100644
--- a/print/lyx-devel/Makefile
+++ b/print/lyx-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= 1.4.1
-PORTREVISION= 1
+PORTVERSION= 1.4.2
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
@@ -26,6 +25,7 @@ CONFLICTS= cjk-lyx-*
OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
ASPELL "Utilize ASPELL library" on \
ISPELL "Depend on ISPELL as well" off
+ALL_TARGET= all check
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
@@ -41,10 +41,6 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 tex2lyx.1 lyxclient.1
-#post-extract:
-# # Removing mention of the bundled boost
-# ${REINPLACE_CMD} -e '/boost\/.*Makefile/d' ${WRKSRC}/configure.ac
-
post-patch:
# Removing mention of the bundled boost
${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' ${WRKSRC}/configure
@@ -53,6 +49,8 @@ post-patch:
${WRKSRC}/src/support/debugstream.h
${REINPLACE_CMD} -e 's,boost/regex\.hpp,boost/cregex.hpp,' \
${WRKSRC}/src/support/filetools.C
+ ${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' \
+ ${WRKSRC}/src/support/tests/test_*
post-configure:
# Removing explicit linking with -lc