aboutsummaryrefslogtreecommitdiff
path: root/print/lyx/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-07-04 22:01:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-07-04 22:01:48 +0000
commite8f96326ceae6768bb0846f48b01b2dfbe29e1d7 (patch)
tree29c67dd75fee164b262c35c8ed43f28f6bfcee6d /print/lyx/Makefile
parentda78f814ff5f377315ed8e4cf565befdefe70b88 (diff)
Notes
Diffstat (limited to 'print/lyx/Makefile')
-rw-r--r--print/lyx/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 0e0acda58be8..3eb971c553c8 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= ${MAJOR_VERSION}.10
+PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -16,23 +16,25 @@ MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
ftp://ftp.chg.ru/pub/X11/lyx/stable/${MAJOR_VERSION}.x/
MAINTAINER= kubito@gmail.com
-COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG) (stable)
-
-LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
+COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
LICENSE= GPLv2
-CONFLICTS= lyx-1.4* lyx-devel-*
-MAJOR_VERSION= 1.6
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
+
+CONFLICTS= lyx-1.[0-9]*
+MAJOR_VERSION= 2.0
+MINOR_VERSION= 0
-USE_BZIP= yes
+USE_XZ= yes
USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build uic_build rcc_build
USE_PYTHON= yes
USE_PERL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+CPPFLAGS= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-frontend=qt4 \
--without-included-boost \
--without-included-gettext \