aboutsummaryrefslogtreecommitdiff
path: root/print/lyx14/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-20 03:25:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-20 03:25:03 +0000
commit8640cd64e2b793d8834f07b9a87a36152bec3411 (patch)
tree89714fea469e9e935cceb7b0cb5bca119a7b7764 /print/lyx14/Makefile
parent8be92a2e06c31b4840c2f4e651a845692250c458 (diff)
downloadports-8640cd64e2b793d8834f07b9a87a36152bec3411.tar.gz
ports-8640cd64e2b793d8834f07b9a87a36152bec3411.zip
Notes
Diffstat (limited to 'print/lyx14/Makefile')
-rw-r--r--print/lyx14/Makefile63
1 files changed, 33 insertions, 30 deletions
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index f25cbb7daa93..f5f4c6969989 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.2.1
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://ftp.sdsc.edu/pub/other/lyx/stable/ \
@@ -19,11 +18,23 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
forms.1:${PORTSDIR}/x11-toolkits/xforms
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
+ latex:${PORTSDIR}/print/teTeX
+
+USE_XPM= yes
+USE_REINPLACE= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_AUTOMAKE_VER= 15
+AUTOMAKE= ${WRKSRC}/autogen.sh
+AUTOCONF= ${TRUE}
+CONFIGURE_ARGS= --with-extra-lib="${X11BASE}/lib ${LOCALBASE}/lib" \
+ --with-extra-inc="${X11BASE}/include ${LOCALBASE}/include"
+MAN1= lyx.1 reLyX.1
.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
-CONFIGURE_ARGS+=--with-pspell
+LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
+CONFIGURE_ARGS+= --with-pspell
.endif
.if defined(WITH_ISPELL)
@@ -31,34 +42,26 @@ RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
pre-everything::
-.if !defined(WITH_ASPELL) && !defined(WITH_ISPELL)
- #
- # If you want to compile with Aspell/Pspell or Ispell support,
- # hit Ctrl-C right now and use
- # "make WITH_ASPELL=yes"
- # or
- # "make WITH_ISPELL=yes"
- #
+.if !defined(WITH_ASPELL)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ASPELL=yes\""
+ @${ECHO_MSG}
.endif
-USE_GMAKE= yes
-USE_XPM= yes
-USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
-USE_PERL5= yes
-USE_AUTOMAKE_VER=15
-AUTOMAKE= ${WRKSRC}/autogen.sh
-AUTOCONF= ${TRUE}
-CONFIGURE_ARGS= --with-extra-lib="${X11BASE}/lib ${LOCALBASE}/lib" \
- --with-extra-inc="${X11BASE}/include/X11 ${X11BASE}/include \
- ${LOCALBASE}/include"
-CONFIGURE_ENV+= LDFLAGS="-L${X11BASE}/lib -lXpm -lX11"
-MAN1= lyx.1 reLyX.1
+.if !defined(WITH_ISPELL)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with Ispell support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ISPELL=yes\""
+ @${ECHO_MSG}
+.endif
+
+post-extract:
+ @${CP} -f ${FILESDIR}/xforms.m4 ${WRKSRC}/config
post-patch:
- @${FIND} ${WRKSRC} -name "configure.in" | ${XARGS} ${REINPLACE_CMD} \
- -e 's|-lxforms|-lforms|g' \
- -e 's|AC_CHECK_LIB(c,|AC_CHECK_FUNC(|g' \
- -e 's|^INSTALL_SCRIPT=|#INSTALL_SCRIPT=|g'
+ @${FIND} ${WRKSRC} -name "configure.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|AC_CHECK_LIB(c,|AC_CHECK_FUNC(|g ; \
+ s|^INSTALL_SCRIPT=|#INSTALL_SCRIPT=|g'
.include <bsd.port.mk>