aboutsummaryrefslogtreecommitdiff
path: root/print/lyx15/Makefile
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1996-10-15 20:49:27 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1996-10-15 20:49:27 +0000
commit3aed493045863160c89efdc12fc269fe6967e289 (patch)
treeba731f3e0009d57513c1a2e317a958fb77f5086c /print/lyx15/Makefile
parentf75d0d0a89e35316157c99c27acb4816986b95ab (diff)
downloadports-3aed493045863160c89efdc12fc269fe6967e289.tar.gz
ports-3aed493045863160c89efdc12fc269fe6967e289.zip
Notes
Diffstat (limited to 'print/lyx15/Makefile')
-rw-r--r--print/lyx15/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
new file mode 100644
index 000000000000..32ba861a166f
--- /dev/null
+++ b/print/lyx15/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: lyx
+# Version required: 0.10.6
+# Date created: Sa 12 Okt 1996 19:20:51 MET DST
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $Id$
+#
+
+DISTNAME= lyx-0.10.6
+CATEGORIES+= print
+MAINTAINER= Andreas Klemm <andreas@klemm.gtn.com>
+
+MASTER_SITES= ftp://ftp.via.ecp.fr/pub/lyx/
+
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+ ispell:${PORTSDIR}/misc/ispell
+LIB_DEPENDS= xforms\\.0\\.:${PORTSDIR}/x11/xforms \
+ Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-extra-lib=/usr/X11R6/lib --with-extra-inc="/usr/X11R6/include /usr/X11R6/include/X11"
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/lyx.1
+.endif
+
+.include <bsd.port.mk>