aboutsummaryrefslogtreecommitdiff
path: root/print/lyx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-04-17 04:25:54 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-04-17 04:25:54 +0000
commit0951fd679deb6960158373afcc50aea34d34d1f3 (patch)
treee31f0964f787d54455f6b363a07efb5c9db7f587 /print/lyx
parent5cc0b532ecb10a0bdf5e8152e033eaec8e40b974 (diff)
downloadports-0951fd679deb6960158373afcc50aea34d34d1f3.tar.gz
ports-0951fd679deb6960158373afcc50aea34d34d1f3.zip
Notes
Diffstat (limited to 'print/lyx')
-rw-r--r--print/lyx/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index fedba1318827..7e1383bbb488 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lyx
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
@@ -18,6 +19,7 @@ COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
CONFLICTS= cjk-lyx-*
@@ -31,14 +33,28 @@ USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch] --exclude ${PORTNAME}-${PORTVERSION}/boost
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
+ --without-included-boost \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 tex2lyx.1 lyxclient.1
USE_REINPLACE= yes
+#post-extract:
+# # Removing mention of the bundled boost
+# ${REINPLACE_CMD} -e '/boost\/.*Makefile/d' ${WRKSRC}/configure.ac
+
+post-patch:
+ # Removing mention of the bundled boost
+ ${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,detail/nullstream,utils/nullstream,' \
+ ${WRKSRC}/src/pch.h ${WRKSRC}/src/support/pch.h \
+ ${WRKSRC}/src/support/debugstream.h
+ ${REINPLACE_CMD} -e 's,boost/regex\.hpp,boost/cregex.hpp,' \
+ ${WRKSRC}/src/support/filetools.C
+
post-configure:
# Removing explicit linking with -lc
${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile