aboutsummaryrefslogtreecommitdiff
path: root/print/mftrace
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-10-13 23:22:02 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-10-13 23:22:02 +0000
commit1aa50ba8836e682a2becebf6addb965e57a31595 (patch)
tree5145d3a87ca248699f7056a8c5f487a2643ea121 /print/mftrace
parentd00dc3632dfab6012803ea50764cfd431d3ff42f (diff)
downloadports-1aa50ba8836e682a2becebf6addb965e57a31595.tar.gz
ports-1aa50ba8836e682a2becebf6addb965e57a31595.zip
Notes
Diffstat (limited to 'print/mftrace')
-rw-r--r--print/mftrace/Makefile34
-rw-r--r--print/mftrace/distinfo2
-rw-r--r--print/mftrace/files/patch-GNUmakefile.in6
-rw-r--r--print/mftrace/pkg-descr4
-rw-r--r--print/mftrace/pkg-message2
-rw-r--r--print/mftrace/pkg-plist3
6 files changed, 34 insertions, 17 deletions
diff --git a/print/mftrace/Makefile b/print/mftrace/Makefile
index 7d4f901740a7..9928a38b9e1d 100644
--- a/print/mftrace/Makefile
+++ b/print/mftrace/Makefile
@@ -1,18 +1,17 @@
# ex:ts=8
-# Ports collection makefile for: pktrace
+# Ports collection makefile for: mftrace (formerly pktrace)
# Date created: Jun w, 2002
# Whom: ijliao
#
# $FreeBSD$
#
-PORTNAME= pktrace
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTNAME= mftrace
+PORTVERSION= 1.0.19
CATEGORIES= print
-MASTER_SITES= http://www.cs.uu.nl/~hanwen/pktrace/
+MASTER_SITES= http://www.xs4all.nl/~hanwen/mftrace/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= trevor@FreeBSD.org
COMMENT= Scalable PostScript (Type1) Fonts for MetaFont
RUN_DEPENDS= mktextfm:${PORTSDIR}/print/teTeX \
@@ -25,13 +24,30 @@ USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
+PLIST= ${WRKDIR}/pkg-plist
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-MAN1= pktrace.1
+MAN1= mftrace.1
+
+pre-everything::
+ @${CAT} ${PKGMESSAGE}
+ @{ECHO_CMD} Pausing ten seconds--press control-C to cancel build.
+ @sleep 10
+
+pre-install:
+ ${RM} -f ${PLIST}
+.for ii in gf2pbm mftrace
+ ${ECHO_CMD} bin/${ii} >> ${PLIST}
+.endfor
+.for ii in afm tfm
+ ${ECHO_CMD} lib/%%PYTHON_VERSION%%/site-packages/${ii}.py >> ${PLIST}
+.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gf2pbm ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/pktrace ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pktrace.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/mftrace ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/mftrace.1 ${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/tfm.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/afm.py ${PYTHON_SITELIBDIR}
.include <bsd.port.mk>
diff --git a/print/mftrace/distinfo b/print/mftrace/distinfo
index 3ee91ccde048..e542fba5c67a 100644
--- a/print/mftrace/distinfo
+++ b/print/mftrace/distinfo
@@ -1 +1 @@
-MD5 (pktrace-1.0.4.tar.gz) = e78cd41f09abf9558133263397498f7b
+MD5 (mftrace-1.0.19.tar.gz) = f121f62bcbd4681df816d2956ed9b607
diff --git a/print/mftrace/files/patch-GNUmakefile.in b/print/mftrace/files/patch-GNUmakefile.in
index bb1450b4db9d..96ec34814e1a 100644
--- a/print/mftrace/files/patch-GNUmakefile.in
+++ b/print/mftrace/files/patch-GNUmakefile.in
@@ -1,11 +1,13 @@
+$FreeBSD$
+
--- GNUmakefile.in.orig Sun Jun 2 23:51:33 2002
+++ GNUmakefile.in Sun Jun 2 23:52:07 2002
@@ -23,7 +23,7 @@
- compile: pktrace gf2pbm
+ compile: mftrace gf2pbm
gf2pbm: gf2pbm.c
- gcc -O2 -Wall -o $@ $<
-+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib -lgnugetopt
++ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib ${LDFLAGS}
README.txt: README.texi
makeinfo --no-split --no-headers --output $@ $<
diff --git a/print/mftrace/pkg-descr b/print/mftrace/pkg-descr
index fb1590554a57..c0ee545cec9b 100644
--- a/print/mftrace/pkg-descr
+++ b/print/mftrace/pkg-descr
@@ -1,8 +1,8 @@
-pktrace is a small Python program that lets you trace a TeX bitmap font into
+mftrace is a small Python program that lets you trace a TeX bitmap font into
a PFA or PFB font (A PostScript Type1 Scalable Font).
Type1 fonts offer many advantages over bitmaps, as they allow PostScript
files to render correctly on printers with many resolutions. Moreover,
Ghostscript can generate much better PDF, if given scalable fonts.
-WWW: http://www.cs.uu.nl/~hanwen/pktrace/
+WWW: http://www.cs.uu.nl/~hanwen/mftrace/
diff --git a/print/mftrace/pkg-message b/print/mftrace/pkg-message
new file mode 100644
index 000000000000..f37f0bb80d70
--- /dev/null
+++ b/print/mftrace/pkg-message
@@ -0,0 +1,2 @@
+*** WARNING:
+*** The source code of mftrace has not been reviewed by the maintainer!
diff --git a/print/mftrace/pkg-plist b/print/mftrace/pkg-plist
deleted file mode 100644
index e49b08dc1961..000000000000
--- a/print/mftrace/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/gf2pbm
-bin/pktrace
-lib/%%PYTHON_VERSION%%/site-packages/tfm.py