aboutsummaryrefslogtreecommitdiff
path: root/print/mup/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 00:58:59 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 00:58:59 +0000
commita14dc49c57fca39bbbb867b97e6af4e6797d43d4 (patch)
tree16fec40d6c3226712d5bac9851c5246d11c2eca2 /print/mup/files
parent798372c85d2d866967c1d34942b2b3c2010d915b (diff)
Notes
Diffstat (limited to 'print/mup/files')
-rw-r--r--print/mup/files/Makefile6
-rw-r--r--print/mup/files/Makefile.disp14
-rw-r--r--print/mup/files/Makefile.fnt5
-rw-r--r--print/mup/files/Makefile.mup57
-rw-r--r--print/mup/files/patch-aa22
-rw-r--r--print/mup/files/patch-ab19
-rw-r--r--print/mup/files/patch-ac11
7 files changed, 134 insertions, 0 deletions
diff --git a/print/mup/files/Makefile b/print/mup/files/Makefile
new file mode 100644
index 000000000000..524ff65e9aa1
--- /dev/null
+++ b/print/mup/files/Makefile
@@ -0,0 +1,6 @@
+# $FreeBSD$
+
+SUBDIR+= mup mkmupfnt mupdisp
+
+.include <bsd.subdir.mk>
+
diff --git a/print/mup/files/Makefile.disp b/print/mup/files/Makefile.disp
new file mode 100644
index 000000000000..c104bde1db6b
--- /dev/null
+++ b/print/mup/files/Makefile.disp
@@ -0,0 +1,14 @@
+PROG= mupdisp
+NOMAN=
+
+SRCS= do_cmd.c \
+ genfile.c \
+ init.c \
+ mupdisp.c \
+ xterm.c
+
+CFLAGS+=-I/usr/X11R6/include
+LDADD+= -L/usr/X11R6/lib -lX11
+
+.include <bsd.prog.mk>
+
diff --git a/print/mup/files/Makefile.fnt b/print/mup/files/Makefile.fnt
new file mode 100644
index 000000000000..fce043933ec8
--- /dev/null
+++ b/print/mup/files/Makefile.fnt
@@ -0,0 +1,5 @@
+PROG= mkmupfnt
+NOMAN=
+
+.include <bsd.prog.mk>
+
diff --git a/print/mup/files/Makefile.mup b/print/mup/files/Makefile.mup
new file mode 100644
index 000000000000..dc4440a8b21b
--- /dev/null
+++ b/print/mup/files/Makefile.mup
@@ -0,0 +1,57 @@
+PROG= mup
+LDADD+= -lm
+NOMAN=
+
+SRCS= abshorz.c \
+ absvert.c \
+ assign.c \
+ beaming.c \
+ beamstem.c \
+ brac.c \
+ charinfo.c \
+ check.c \
+ debug.c \
+ errors.c \
+ extchtbl.c \
+ font.c \
+ fontdata.c \
+ globals.c \
+ grpsyl.c \
+ lex.c \
+ locvar.c \
+ lyrics.c \
+ macros.c \
+ main.c \
+ mainlist.c \
+ map.c \
+ midi.c \
+ midiutil.c \
+ mkchords.c \
+ muschtbl.c \
+ nxtstrch.c \
+ parstuff.c \
+ phrase.c \
+ plutils.c \
+ print.c \
+ prntdata.c \
+ prntmisc.c \
+ prnttab.c \
+ prolog.c \
+ range.c \
+ rational.c \
+ relvert.c \
+ restsyl.c \
+ roll.c \
+ setgrps.c \
+ setnotes.c \
+ ssv.c \
+ stuff.c \
+ symtbl.c \
+ tie.c \
+ trantab.c \
+ trnspose.c \
+ undrscre.c \
+ utils.c \
+ ytab.c
+
+.include <bsd.prog.mk>
diff --git a/print/mup/files/patch-aa b/print/mup/files/patch-aa
new file mode 100644
index 000000000000..e95febbaefd8
--- /dev/null
+++ b/print/mup/files/patch-aa
@@ -0,0 +1,22 @@
+--- mupdisp/mupdisp.c.orig Wed Nov 27 20:49:30 2002
++++ mupdisp/mupdisp.c Wed Nov 27 23:03:09 2002
+@@ -45,6 +45,10 @@
+ * chmod 4755 mupdisp
+ */
+
++#include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <sys/signal.h>
+
+ #include "mupdisp.h"
+ #ifdef __WATCOMC__
+@@ -112,7 +116,7 @@
+ /* arrange to clean up temp files. Note that the user interface
+ * will probably have its own cleanup */
+ for (n = 0; n < NSIG; n++) {
+- if (n != SIGKILL && n != SIGCLD && n != SIGWINCH) {
++ if (n != SIGKILL && n != SIGCHLD && n != SIGWINCH) {
+ signal(n, generalcleanup);
+ }
+ }
diff --git a/print/mup/files/patch-ab b/print/mup/files/patch-ab
new file mode 100644
index 000000000000..9ff9bb04ec29
--- /dev/null
+++ b/print/mup/files/patch-ab
@@ -0,0 +1,19 @@
+--- mupdisp/mupdisp.h.orig Sun Oct 5 17:53:43 2003
++++ mupdisp/mupdisp.h Sun Oct 5 17:54:05 2003
+@@ -12,8 +12,7 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <stdlib.h>
+-#include <malloc.h>
+-#if !defined(linux) && !defined(__EMX__)
++#if !defined(linux) && !defined(__EMX__) && !defined(__FreeBSD__)
+ /* undef SIGCHLD to avoid conflict with Xos.h */
+ #undef SIGCHLD
+ #endif
+@@ -146,6 +145,3 @@
+ extern void init P((void));
+ extern void do_cmd P((int c));
+
+-extern char *getenv();
+-extern long ftell();
+-extern long lseek();
diff --git a/print/mup/files/patch-ac b/print/mup/files/patch-ac
new file mode 100644
index 000000000000..3904bf0268ad
--- /dev/null
+++ b/print/mup/files/patch-ac
@@ -0,0 +1,11 @@
+--- mupdisp/dispttyp.h.orig Sat Jun 22 12:30:53 2002
++++ mupdisp/dispttyp.h Wed Nov 27 23:28:55 2002
+@@ -9,7 +9,7 @@
+ * Support for other terminal types could be added in the future. */
+
+ #ifdef i386
+-#if !defined(linux) && !defined(__EMX__)
++#if !defined(linux) && !defined(__EMX__) && !defined(__FreeBSD__)
+ #define AT386 1
+ #endif
+ #endif