aboutsummaryrefslogtreecommitdiff
path: root/print/p5-XML-ApacheFOP/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-03 03:06:50 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-03 03:06:50 +0000
commita8e95ccf68f0235f3f463dbb2a5beffaf34f6abf (patch)
tree6c640926078be914ac29fbce5ae6e6df53ce0db7 /print/p5-XML-ApacheFOP/Makefile
parentc2db2c577e7f0de136c8e9a26539d460d0aa2316 (diff)
downloadports-a8e95ccf68f0235f3f463dbb2a5beffaf34f6abf.tar.gz
ports-a8e95ccf68f0235f3f463dbb2a5beffaf34f6abf.zip
Notes
Diffstat (limited to 'print/p5-XML-ApacheFOP/Makefile')
-rw-r--r--print/p5-XML-ApacheFOP/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/print/p5-XML-ApacheFOP/Makefile b/print/p5-XML-ApacheFOP/Makefile
new file mode 100644
index 000000000000..933fd55be194
--- /dev/null
+++ b/print/p5-XML-ApacheFOP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-XML-ApacheFOP
+# Date created: 27 Feb 2006
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-ApacheFOP
+PORTVERSION= 0.03
+CATEGORIES= print perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Access Apache FOP from Perl to create PDF files using XSL-FO
+
+BUILD_DEPENDS= ${SITE_PERL}/Java.pm:${PORTSDIR}/devel/p5-Java \
+ ${LOCALBASE}/share/fop/build/fop.jar:${PORTSDIR}/textproc/fop
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::ApacheFOP.3
+
+.include <bsd.port.mk>