aboutsummaryrefslogtreecommitdiff
path: root/print/p5-XML-ApacheFOP
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-03 03:06:50 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-03 03:06:50 +0000
commita8e95ccf68f0235f3f463dbb2a5beffaf34f6abf (patch)
tree6c640926078be914ac29fbce5ae6e6df53ce0db7 /print/p5-XML-ApacheFOP
parentc2db2c577e7f0de136c8e9a26539d460d0aa2316 (diff)
downloadports-a8e95ccf68f0235f3f463dbb2a5beffaf34f6abf.tar.gz
ports-a8e95ccf68f0235f3f463dbb2a5beffaf34f6abf.zip
Notes
Diffstat (limited to 'print/p5-XML-ApacheFOP')
-rw-r--r--print/p5-XML-ApacheFOP/Makefile26
-rw-r--r--print/p5-XML-ApacheFOP/distinfo3
-rw-r--r--print/p5-XML-ApacheFOP/pkg-descr2
-rw-r--r--print/p5-XML-ApacheFOP/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/print/p5-XML-ApacheFOP/Makefile b/print/p5-XML-ApacheFOP/Makefile
new file mode 100644
index 000000000000..933fd55be194
--- /dev/null
+++ b/print/p5-XML-ApacheFOP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-XML-ApacheFOP
+# Date created: 27 Feb 2006
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-ApacheFOP
+PORTVERSION= 0.03
+CATEGORIES= print perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Access Apache FOP from Perl to create PDF files using XSL-FO
+
+BUILD_DEPENDS= ${SITE_PERL}/Java.pm:${PORTSDIR}/devel/p5-Java \
+ ${LOCALBASE}/share/fop/build/fop.jar:${PORTSDIR}/textproc/fop
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::ApacheFOP.3
+
+.include <bsd.port.mk>
diff --git a/print/p5-XML-ApacheFOP/distinfo b/print/p5-XML-ApacheFOP/distinfo
new file mode 100644
index 000000000000..18c2ec998198
--- /dev/null
+++ b/print/p5-XML-ApacheFOP/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-ApacheFOP-0.03.tar.gz) = 8652fb3917b59bfdcd3d343710eca495
+SHA256 (XML-ApacheFOP-0.03.tar.gz) = 6606e427a6dfce05dd36f3471ae4c93d719801b70e8c3b133259d8f3200d5b60
+SIZE (XML-ApacheFOP-0.03.tar.gz) = 7089
diff --git a/print/p5-XML-ApacheFOP/pkg-descr b/print/p5-XML-ApacheFOP/pkg-descr
new file mode 100644
index 000000000000..f8d43ffb9167
--- /dev/null
+++ b/print/p5-XML-ApacheFOP/pkg-descr
@@ -0,0 +1,2 @@
+XML::ApacheFOP allows you to create PDFs (or other output types) using
+Apache FOP.
diff --git a/print/p5-XML-ApacheFOP/pkg-plist b/print/p5-XML-ApacheFOP/pkg-plist
new file mode 100644
index 000000000000..d1dca8b91b5f
--- /dev/null
+++ b/print/p5-XML-ApacheFOP/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/XML/ApacheFOP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/ApacheFOP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/ApacheFOP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML