aboutsummaryrefslogtreecommitdiff
path: root/print/pdflib/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-01-27 00:24:56 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-01-27 00:24:56 +0000
commitc4db8f4fb7aac11da8d388187630bc6a7340ca4c (patch)
tree0b9f4b6310663605a6bb9e09218e8fee75650c02 /print/pdflib/Makefile
parent44f6e99f4e94e9037c9f82717031cd4940c5a330 (diff)
downloadports-c4db8f4fb7aac11da8d388187630bc6a7340ca4c.tar.gz
ports-c4db8f4fb7aac11da8d388187630bc6a7340ca4c.zip
Notes
Diffstat (limited to 'print/pdflib/Makefile')
-rw-r--r--print/pdflib/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index 3d378c6aec11..9ebd97d39ef6 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= pdflib
-PORTVERSION= 5.0.2
+PORTVERSION= 5.0.3
CATEGORIES= print
-MASTER_SITES= http://www.pdflib.com/products/pdflib/download/
+MASTER_SITES= http://www.pdflib.com/products/pdflib/download/503src/
DISTNAME= PDFlib-Lite-${PORTVERSION}-Unix-src
MAINTAINER= ale@FreeBSD.org
@@ -19,6 +19,8 @@ RESTRICTED= "many odd restrictions on usage and distribution"
LATEST_LINK?= ${PORTNAME}
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
+USE_GNOME= lthack
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-cxx \
@@ -36,6 +38,9 @@ CONFIGURE_ARGS+=--with-perl=no
PLIST_SUB= PERL="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|\(PDFLIB_LTCURRENT\)=4|\1=6|g" ${WRKSRC}/configure
+
post-install:
${MKDIR} ${DATADIR}/fonts
${INSTALL_DATA} ${WRKSRC}/fonts/* ${DATADIR}/fonts