aboutsummaryrefslogtreecommitdiff
path: root/print/pecl-panda/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-06-25 14:39:22 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-06-25 14:39:22 +0000
commita85854b8a7a697f7f24f8451824cfcdedc1c8dde (patch)
tree650d274367101347f2b350959a3a0d257b04d054 /print/pecl-panda/Makefile
parentdb2c514e2c1b4edf76803952066e594d973966fe (diff)
downloadports-a85854b8a7a697f7f24f8451824cfcdedc1c8dde.tar.gz
ports-a85854b8a7a697f7f24f8451824cfcdedc1c8dde.zip
Notes
Diffstat (limited to 'print/pecl-panda/Makefile')
-rw-r--r--print/pecl-panda/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/print/pecl-panda/Makefile b/print/pecl-panda/Makefile
new file mode 100644
index 000000000000..4fa03b137d00
--- /dev/null
+++ b/print/pecl-panda/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pecl-panda
+# Date created: 25 Jun 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= panda
+PORTVERSION= 0.1.0
+CATEGORIES= print pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PECL extension to create PDF documents
+
+LIB_DEPENDS= panda.0:${PORTSDIR}/print/panda
+
+USE_PHP= yes
+USE_PHPIZE= yes
+
+CONFIGURE_ARGS= --with-panda=${LOCALBASE}
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/modules/panda.so \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>