aboutsummaryrefslogtreecommitdiff
path: root/print/pecl-ps
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-26 09:41:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-26 09:41:27 +0000
commit8bc219bd4f952b67c52b4360e44f12753b8ac76b (patch)
tree42d25add48a03adf4b5ee83672ce9e5e8818e59e /print/pecl-ps
parent5cebdffee5de79b3eff6d627cf5369d3b088ccbf (diff)
downloadports-8bc219bd4f952b67c52b4360e44f12753b8ac76b.tar.gz
ports-8bc219bd4f952b67c52b4360e44f12753b8ac76b.zip
Notes
Diffstat (limited to 'print/pecl-ps')
-rw-r--r--print/pecl-ps/Makefile2
-rw-r--r--print/pecl-ps/files/patch-ps.c66
2 files changed, 67 insertions, 1 deletions
diff --git a/print/pecl-ps/Makefile b/print/pecl-ps/Makefile
index b5646354743b..529de075e9aa 100644
--- a/print/pecl-ps/Makefile
+++ b/print/pecl-ps/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ps
PORTVERSION= 1.3.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/print/pecl-ps/files/patch-ps.c b/print/pecl-ps/files/patch-ps.c
new file mode 100644
index 000000000000..d89431ac996c
--- /dev/null
+++ b/print/pecl-ps/files/patch-ps.c
@@ -0,0 +1,66 @@
+--- ps.c 2006-05-31 23:09:47.000000000 +1000
++++ ps.c 2008-09-22 13:50:07.000000000 +1000
+@@ -1285,7 +1285,8 @@
+ zval *zps;
+ char *type, *filename, *image, *stringparam = NULL;
+ int type_len, filename_len, stringparam_len;
+- int imageid, intparam = 0;
++ long imageid;
++ int intparam = 0;
+ PSDoc *ps;
+
+ if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rss|sl", &zps, &type, &type_len, &filename, &filename_len, &stringparam, &stringparam_len, &intparam)) {
+@@ -1316,7 +1317,7 @@
+ {
+ zval **arg1, **arg2;
+ int i, j, color, count;
+- int imageid;
++ long imageid;
+ gdImagePtr im;
+ unsigned char *buffer, *ptr;
+ PSDoc *ps;
+@@ -1382,7 +1383,7 @@
+ PHP_FUNCTION(ps_close_image)
+ {
+ zval *zps;
+- int imageid;
++ long imageid;
+ PSDoc *ps;
+
+ if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rl", &zps, &imageid)) {
+@@ -1400,7 +1401,7 @@
+ PHP_FUNCTION(ps_place_image)
+ {
+ zval *zps;
+- int imageid;
++ long imageid;
+ double x, y, scale;
+ PSDoc *ps;
+
+@@ -1761,7 +1762,7 @@
+ zval **arg1, **arg2, **arg3, **arg4, **arg5, **arg6, **arg7;
+ PSDoc *ps;
+ char *image;
+- int imageid;
++ long imageid;
+
+ if (ZEND_NUM_ARGS() != 7 || zend_get_parameters_ex(7, &arg1, &arg2, &arg3, &arg4, &arg5, &arg6, &arg7) == FAILURE) {
+ WRONG_PARAM_COUNT;
+@@ -1802,7 +1803,7 @@
+ char *type, *params, *source, *data;
+ int type_len, params_len, source_len, data_len;
+ int length, width, height, components, bpc;
+- int imageid;
++ long imageid;
+ char *image;
+ PSDoc *ps;
+
+@@ -2024,7 +2025,7 @@
+ * Add an existing image as thumbnail for the current page. */
+ PHP_FUNCTION(ps_add_thumbnail) {
+ zval *zps;
+- int imageid;
++ long imageid;
+ PSDoc *ps;
+
+ if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rl", &zps, &imageid)) {