aboutsummaryrefslogtreecommitdiff
path: root/print/pfaedit/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-29 19:00:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-29 19:00:22 +0000
commit8943f01e8b58e7bde301590a128c84097cc3ae2e (patch)
tree1ccf4c06d3af80d4e42a54a13d2346b17aee354f /print/pfaedit/Makefile
parent4140ce711870433f1663c06c29d7a44c86148a01 (diff)
upgrade to 20020627
PR: 39983 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=62180
Diffstat (limited to 'print/pfaedit/Makefile')
-rw-r--r--print/pfaedit/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/print/pfaedit/Makefile b/print/pfaedit/Makefile
index da7e8ec2351a..1106cb23ab26 100644
--- a/print/pfaedit/Makefile
+++ b/print/pfaedit/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_GMAKE= yes
USE_XLIB= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2"
@@ -32,11 +33,11 @@ ALL_TARGET= pfaedit
MAN1= pfaedit.1 sfddiff.1
-DIST_VER= 020518
+DIST_VER= 020627
EXTRACT_ONLY= ${PORTNAME}_full-${DIST_VER}.tgz cidmaps.tgz
.if !defined(NOPORTDOCS)
-DOC_VER= 020416
+DOC_VER= 020626
DOCFILE= ${PORTNAME}_htdocs-${DOC_VER}.tgz
.endif
@@ -49,16 +50,15 @@ post-extract:
.endif
post-patch:
- ${PERL} -pi.orig -e \
+ ${REINPLACE_CMD} -e \
's,/usr/include/freetype2,${PREFIX}/include/freetype2 -I${PREFIX}/include,g' \
${WRKSRC}/configure ${WRKSRC}/configure.in \
${WRKSRC}/configure.pfaedit ${WRKSRC}/configure.pfaedit.in \
${WRKSRC}/configure.static.in \
${WRKSRC}/configure.ttfmod ${WRKSRC}/configure.ttfmod.in
- ${PERL} -pi.orig -e 's,/usr/share/,${PREFIX}/share/,g' \
+ ${REINPLACE_CMD} -e 's,/usr/share/,${PREFIX}/share/,g' \
${WRKSRC}/pfaedit/pfaedit.1
- ${PERL} -pi.orig -e 's,/usr/pkg/,${PREFIX}/,g' \
- ${WRKSRC}/*/[mM]akefile.*
+ ${REINPLACE_CMD} -e 's,/usr/pkg/,${PREFIX}/,g' ${WRKSRC}/*/[mM]akefile.*
post-install:
${MKDIR} ${DOCSDIR}