aboutsummaryrefslogtreecommitdiff
path: root/print/pkfonts300/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-03-21 17:25:02 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-03-21 17:25:02 +0000
commit4dcaf362d3a9da34dea3f0f6db327cae409ef009 (patch)
tree05238bcbaae84b1babaef682c16b0d232b1fbe9a /print/pkfonts300/Makefile
parent41ed4b9a53ad60c6a67a07c5359bfa520b441330 (diff)
downloadports-4dcaf362d3a9da34dea3f0f6db327cae409ef009.tar.gz
ports-4dcaf362d3a9da34dea3f0f6db327cae409ef009.zip
Notes
Diffstat (limited to 'print/pkfonts300/Makefile')
-rw-r--r--print/pkfonts300/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/print/pkfonts300/Makefile b/print/pkfonts300/Makefile
new file mode 100644
index 000000000000..4b2d57c7f48d
--- /dev/null
+++ b/print/pkfonts300/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: English PK fonts
+# Version required: ?
+# Date created: 16 Mar 1996
+# Whom: Hideaki Ohmon <ohmon@sfc.keio.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= pkfonts
+PKGNAME= pkfonts${RESOLUTION}-1.0
+CATEGORIES+= print
+MASTER_SITES= ftp://ftp.eos.hokudai.ac.jp/pub/TeX/fonts/
+DISTFILES= pk${RESOLUTION}.tar.gz
+# see below for RESOLUTION definition
+
+MAINTAINER= ohmon@sfc.keio.ac.jp
+
+DIST_SUBDIR= pkfonts
+EXTRACT_CMD= /usr/bin/true # extracted directly in install target
+NO_BUILD= yes
+
+.if !defined(RESOLUTION)
+RESOLUTION= 300
+RESOLUTION_UNSPECIFIED= yes
+.else
+.if ${RESOLUTION} != 118 && ${RESOLUTION} != 240 && \
+ ${RESOLUTION} != 300 && ${RESOLUTION} != 400
+RESOLUTION_INVALID= yes
+.endif
+.endif
+
+pre-fetch:
+.if defined(RESOLUTION_UNSPECIFIED)
+ @echo "Using ${RESOLUTION}dpi English PK fonts."
+ @echo "Set the environment variable RESOLUTION if you want"
+ @echo "it to use other resolutions."
+ @echo "Possible values are: 118, 240, 300 (default) and 400."
+.elif defined(RESOLUTION_INVALID)
+ @echo "Error: invalid value for RESOLUTION: \"${RESOLUTION}\""
+ @echo "Possible values are: 118, 240, 300 (default) and 400."
+ @/usr/bin/false
+.endif
+
+do-install:
+ mkdir -p ${PREFIX}/lib/fonts
+ tar -C ${PREFIX}/lib/fonts -xzf ${DISTDIR}/${DISTFILES}
+ @cp ${PKGDIR}/${RESOLUTION}.list ${PKGDIR}/PLIST
+
+.include <bsd.port.mk>