aboutsummaryrefslogtreecommitdiff
path: root/print/pktrace/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-02 17:03:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-02 17:03:02 +0000
commitc9c024ac0fa2622f53295f1b823d49d996ba0e33 (patch)
tree40b4f83e8b271c7266ba19e63b0ea4b3c8c6a437 /print/pktrace/Makefile
parentf4c321326cbf0d0bc42557417727b9fdcfd21cdd (diff)
downloadports-c9c024ac0fa2622f53295f1b823d49d996ba0e33.tar.gz
ports-c9c024ac0fa2622f53295f1b823d49d996ba0e33.zip
Notes
Diffstat (limited to 'print/pktrace/Makefile')
-rw-r--r--print/pktrace/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/print/pktrace/Makefile b/print/pktrace/Makefile
new file mode 100644
index 000000000000..4b92d96c85c4
--- /dev/null
+++ b/print/pktrace/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: pktrace
+# Date created: Jun w, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pktrace
+PORTVERSION= 1.0.4
+CATEGORIES= print
+MASTER_SITES= http://www.cs.uu.nl/~hanwen/pktrace/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+RUN_DEPENDS= mktextfm:${PORTSDIR}/print/teTeX \
+ autotrace:${PORTSDIR}/graphics/autotrace \
+ t1asm:${PORTSDIR}/print/t1utils \
+ pfaedit:${PORTSDIR}/print/pfaedit
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+MAN1= pktrace.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gf2pbm ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/pktrace ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pktrace.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/tfm.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>