aboutsummaryrefslogtreecommitdiff
path: root/print/pslib
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 12:40:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 12:40:32 +0000
commit61000f23278e2896df05e4dcb2fa6fcdf1c33643 (patch)
tree2eef8dc8057844b13440984edd0115f961a53036 /print/pslib
parent4e29df1229e8f7aeb6bce65481987a85a1ee53b5 (diff)
downloadports-61000f23278e2896df05e4dcb2fa6fcdf1c33643.tar.gz
ports-61000f23278e2896df05e4dcb2fa6fcdf1c33643.zip
Notes
Diffstat (limited to 'print/pslib')
-rw-r--r--print/pslib/Makefile37
1 files changed, 17 insertions, 20 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 09afe26070c7..b23d9bfdb2f2 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: pslib
-# Date created: Jul 13, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= pslib
PORTVERSION= 0.4.5
@@ -19,7 +14,9 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-USE_GNOME= gnomehack intlhack pkgconfig
+USES= pathfix
+USE_PKGCONFIG= build
+USE_GNOME= intlhack
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
@@ -27,13 +24,13 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
USE_LDCONFIG= yes
-OPTIONS= EXAMPLES "Install additional examples" On \
- MAN "Install manual pages" On \
- NLS "Native language support" On
+OPTIONS_DEFINE= EXAMPLES MAN NLS
+OPTIONS_DEFAULT= MAN NLS
+MAN_DESC= Manual pages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
EX_NAME= pslib-examples-0.0.10
EX_WRKSRC= ${WRKDIR}/${EX_NAME}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EX_NAME}${EXTRACT_SUFX}
@@ -42,7 +39,7 @@ PLIST_SUB+= EXAMPLES=""
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if !defined(WITHOUT_MAN)
+.if ${PORT_OPTIONS:MMAN}
BUILD_DEPENDS+= ${LOCALBASE}/bin/docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
${LOCALBASE}/bin/docbook2man:${PORTSDIR}/textproc/docbook-utils
MAN3!= ${CAT} ${FILESDIR}/man3
@@ -51,25 +48,25 @@ MAN3!= ${CAT} ${FILESDIR}/man3
CONFIGURE_ENV+= ac_cv_prog_DOC_TO_MAN=""
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ENV+= ac_cv_header_libintl_h=no
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ENV+= ac_cv_header_libintl_h=no
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|@USE_NLS@|no|g' ${WRKSRC}/po/Makefile.in.in
.endif
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} -m 0755 ${EXAMPLESDIR}
@${RM} -f ${EX_WRKSRC}/Makefile.unix ${EX_WRKSRC}/ChangeLog \
${EX_WRKSRC}/CMakeLists.txt
cd ${EX_WRKSRC} && ${PAX} -rw * ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>