aboutsummaryrefslogtreecommitdiff
path: root/print/psutils-letter
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-20 04:15:15 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-20 04:15:15 +0000
commit751790b51ae4c1152e8944cbaf99d49b1377e95b (patch)
tree086c03d44a933a34d3f086e2ad7487d5d6b2872d /print/psutils-letter
parent1007d89b1e30bdb9e77bc765b023f4e3c60f6982 (diff)
downloadports-751790b51ae4c1152e8944cbaf99d49b1377e95b.tar.gz
ports-751790b51ae4c1152e8944cbaf99d49b1377e95b.zip
Notes
Diffstat (limited to 'print/psutils-letter')
-rw-r--r--print/psutils-letter/Makefile34
1 files changed, 9 insertions, 25 deletions
diff --git a/print/psutils-letter/Makefile b/print/psutils-letter/Makefile
index a85c1dde9629..4843ac0aa213 100644
--- a/print/psutils-letter/Makefile
+++ b/print/psutils-letter/Makefile
@@ -1,9 +1,9 @@
-# New ports collection makefile for: psutils
+# New ports collection makefile for: psutils (letter)
# Version required: 1.16
# Date created: 21 September 1994
# Whom: jmz & David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.16 1998/03/12 16:12:09 jmz Exp $
+# $Id: Makefile,v 1.17 1998/10/30 08:35:38 asami Exp $
#
DISTNAME= psutils-p17
@@ -13,8 +13,6 @@ MASTER_SITES= ftp://ftp.dcs.ed.ac.uk/pub/ajcd/
MAINTAINER= jmz@FreeBSD.org
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= letter a4
WRKSRC= ${WRKDIR}/psutils
MAKE_FLAGS?= PAPER=${PAPERSIZE} -f
MAN1= psbook.1 psselect.1 pstops.1 epsffit.1 psnup.1 psresize.1 \
@@ -22,21 +20,8 @@ MAN1= psbook.1 psselect.1 pstops.1 epsffit.1 psnup.1 psresize.1 \
fixpspps.1 fixtpps.1 fixwfwps.1 fixwpps.1 fixwwps.1 \
extractres.1 includeres.1 fixscribeps.1 psmerge.1
-
-##package:: letter a4
-
-letter::
- ${MAKE} PAPERSIZE=letter
-
-letter-install::
- ${MAKE} PAPERSIZE=letter install
-
-a4::
- ${MAKE} PAPERSIZE=a4
-
-
.if !defined(PAPERSIZE)
-PAPERSIZE=a4
+PAPERSIZE=letter
PAPERSIZE_UNSPECIFIED= yes
.else
.if ${PAPERSIZE} != A3 && ${PAPERSIZE} != a3 && ${PAPERSIZE} != A4 \
@@ -46,7 +31,11 @@ PAPERSIZE_UNSPECIFIED= yes
&& ${PAPERSIZE} != ledger && ${PAPERSIZE} != tabloid \
&& ${PAPERSIZE} != statement && ${PAPERSIZE} != executive \
&& ${PAPERSIZE} != folio && ${PAPERSIZE} != quarto && ${PAPERSIZE} != 10x14
-PAPERSIZE_INVALID= yes
+.BEGIN:
+ @${ECHO} "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @${ECHO} "Possible values are: A3, A4 (default), A5, B5, letter, legal,"
+ @${ECHO} " ledger, tabloid, statement, executive, folio, quarto, and 10x14."
+ @${FALSE}
.endif
.endif
@@ -55,13 +44,8 @@ pre-fetch:
@echo "Defaulting to ${PAPERSIZE} sized paper."
@echo ""
@echo "Set the environment variable PAPERSIZE if you want to use other sizes."
- @echo "Possible values are: A3, A4 (default), A5, B5, letter, legal,"
+ @echo "Possible values are: A3, A4, A5, B5, letter, legal,"
@echo " ledger, tabloid, statement, executive, folio, quarto, and 10x14."
-.elif defined(PAPERSIZE_INVALID)
- @echo "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @echo "Possible values are: A3, A4 (default), A5, B5, letter, legal,"
- @echo " ledger, tabloid, statement, executive, folio, quarto, and 10x14."
- @${FALSE}
.endif
.include <bsd.port.mk>