aboutsummaryrefslogtreecommitdiff
path: root/print/pup
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 18:57:13 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 18:57:13 +0000
commit8bca8e1875941ef4822f73b830bd6a81fc45ffd6 (patch)
tree0e77f5907c9afd260b32c4e063d8f17a9dffd4ca /print/pup
parent9db693901122f094ff6cd56710935fcc08199c1a (diff)
Notes
Diffstat (limited to 'print/pup')
-rw-r--r--print/pup/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/print/pup/Makefile b/print/pup/Makefile
index 81691c45edec..216575881f53 100644
--- a/print/pup/Makefile
+++ b/print/pup/Makefile
@@ -5,28 +5,28 @@ PORTNAME= pup
PORTVERSION= 1.1
PORTREVISION= 4
CATEGORIES= print
-#MASTER_SITES= http://download.sourceforge.net/pup/
MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK+ printer setup and maintaining tool
+COMMENT= GTK+ printer setup and maintaining tool
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
-PLIST_FILES= bin/pup
USE_GNOME= gtk12
-WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/
+PLIST_FILES= bin/pup
-NO_STAGE= yes
post-patch:
- @echo ${WRKSRC}
- @${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g' ${WRKSRC}/Makefile
-
-.for file in lexgui.c build_choices.c proutines.c
- @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e \
+ 's| =| ?=| ; \
+ s|$$(CC) $$(SRCS)|$$(CC) $$(CFLAGS) $$(SRCS)| ; \
+ s|gtk-config|$$(GTK_CONFIG)|' ${WRKSRC}/Makefile
+.for i in lexgui.c build_choices.c proutines.c
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/${i}
.endfor
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/pup ${PREFIX}/bin/
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} pup ${STAGEDIR}${PREFIX}/bin)
.include <bsd.port.mk>