aboutsummaryrefslogtreecommitdiff
path: root/print/py-cups
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2008-03-23 16:19:06 +0000
committerMichael Johnson <ahze@FreeBSD.org>2008-03-23 16:19:06 +0000
commiteb9c8a9887d36fd73557549a7b6e17d95608cd0b (patch)
tree405e5c41617efc5047ab2a9bbb7354107ec2277b /print/py-cups
parent3f94295b9a6c6ed4fa5ddc9a03b440d8206b1775 (diff)
downloadports-eb9c8a9887d36fd73557549a7b6e17d95608cd0b.tar.gz
ports-eb9c8a9887d36fd73557549a7b6e17d95608cd0b.zip
Notes
Diffstat (limited to 'print/py-cups')
-rw-r--r--print/py-cups/Makefile29
-rw-r--r--print/py-cups/distinfo3
-rw-r--r--print/py-cups/files/patch-cupsppd.c11
-rw-r--r--print/py-cups/pkg-descr3
4 files changed, 46 insertions, 0 deletions
diff --git a/print/py-cups/Makefile b/print/py-cups/Makefile
new file mode 100644
index 000000000000..4c032f09e0f7
--- /dev/null
+++ b/print/py-cups/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-cups
+# Date created: 2008-03-20
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/print/py-cups/Makefile,v 1.1 2008/03/20 13:55:32 ahze Exp $
+
+PORTNAME= cups
+PORTVERSION= 1.9.37
+CATEGORIES= print
+MASTER_SITES= http://cyberelk.net/tim/data/pycups/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= CUPS bindings for Python
+
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+
+USE_PYTHON= yes
+USE_BZIP2= yes
+USE_PYDISTUTILS= yes
+CFLAGS+= -I${LOCALBASE}/include -DVERSION=\\\"${PORTVERSION}\\\"
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+PYDISTUTILS_EGGINFO=${PORTNAME}-1.0-py2.5.egg-info
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/cups.so
+
+.include <bsd.port.mk>
diff --git a/print/py-cups/distinfo b/print/py-cups/distinfo
new file mode 100644
index 000000000000..91bc0dc00a2b
--- /dev/null
+++ b/print/py-cups/distinfo
@@ -0,0 +1,3 @@
+MD5 (pycups-1.9.37.tar.bz2) = bb9c0fecb8ef37942f3a5de7fa5d16a8
+SHA256 (pycups-1.9.37.tar.bz2) = 1d0a2402307614dc13c4fe237e2d3092677aa64127e0897c0524558b3add81a6
+SIZE (pycups-1.9.37.tar.bz2) = 36857
diff --git a/print/py-cups/files/patch-cupsppd.c b/print/py-cups/files/patch-cupsppd.c
new file mode 100644
index 000000000000..83b68ca60b3c
--- /dev/null
+++ b/print/py-cups/files/patch-cupsppd.c
@@ -0,0 +1,11 @@
+--- cupsppd.c.orig 2008-03-20 10:16:42.000000000 -0400
++++ cupsppd.c 2008-03-20 10:17:16.000000000 -0400
+@@ -451,7 +451,7 @@
+ return PyBool_FromLong (nondefaults_marked);
+ }
+
+-#ifdef __SVR4
++#if 1
+ /*
+ * A rudimentary emulation of getline() for systems that dont support it
+ * natively. Since this is used for PPD file reading, it assumes (possibly
diff --git a/print/py-cups/pkg-descr b/print/py-cups/pkg-descr
new file mode 100644
index 000000000000..1b76ec48e4ed
--- /dev/null
+++ b/print/py-cups/pkg-descr
@@ -0,0 +1,3 @@
+CUPS bindings for Python
+
+WWW: http://cyberelk.net/tim/software/pycups/