aboutsummaryrefslogtreecommitdiff
path: root/print/py-reportlab1/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2014-02-25 12:44:10 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2014-02-25 12:44:10 +0000
commit0cbe65e47c9209d69ce010b5ab926c714387ecb1 (patch)
treebc7942759dbfb01fc52a7089e3edbbfb635ff176 /print/py-reportlab1/Makefile
parent06f83c7e994adeed9e1afcb54d28015affc5de4c (diff)
Notes
Diffstat (limited to 'print/py-reportlab1/Makefile')
-rw-r--r--print/py-reportlab1/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/print/py-reportlab1/Makefile b/print/py-reportlab1/Makefile
new file mode 100644
index 000000000000..94840d99cb4f
--- /dev/null
+++ b/print/py-reportlab1/Makefile
@@ -0,0 +1,51 @@
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= reportlab
+PORTVERSION= 1.21.2
+PORTREVISION= 3
+CATEGORIES= print python
+MASTER_SITES= http://www.reportlab.com/ftp/ \
+ ${MASTER_SITE_LOCAL:S/$/:accel/} \
+ http://www.cs.nctu.edu.tw/~lwhsu/ports/distfiles/:accel
+MASTER_SITE_SUBDIR= erwin/:accel
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+DISTFILES= reportlab-${PORTVERSION}.tar.gz \
+ rl_accel-3004.tgz:accel
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Library to create PDF documents using the Python language
+
+CONFLICTS= py*-reportlab[^1]-[^1].* \
+ py*-reportlab-[^1].*
+
+PORTSCOUT= ignore:1 # Last version of 1.X branch
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+PYDISTUTILS_PKGNAME= Reportlab
+
+WRKSRC= ${WRKDIR}/reportlab_${PORTVERSION:S/./_/g}/reportlab
+MAKE_ENV= PACKAGE_PATH="${REPORTLABDIR}"
+
+REPORTLABDIR= ${PYTHONPREFIX_SITELIBDIR}/reportlab
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
+PORTDOCS= RML_UserGuide.pdf RML_UserGuide_1_0.pdf diagradoc.pdf graphguide.pdf \
+ graphics_reference.pdf reference.pdf userguide.pdf
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/rl_config.py
+ @${REINPLACE_CMD} -e 's#with#with26#g' ${WRKSRC}/lib/PyFontify.py
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${CP} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
+.endfor
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>