aboutsummaryrefslogtreecommitdiff
path: root/print/qpdfview
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-25 14:38:47 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-25 14:38:47 +0000
commitadedf85d3246af4fa1f20c96de74747937297895 (patch)
treeee60724419a748003cf263a38e17e4a66875bb30 /print/qpdfview
parent2e5eaf89c9f1e96de1f843a5a5ad145b7623dd03 (diff)
downloadports-adedf85d3246af4fa1f20c96de74747937297895.tar.gz
ports-adedf85d3246af4fa1f20c96de74747937297895.zip
- Convert to USES=qmake
- Use options helpers - Add stage support - Update port comment/description - Fix PDF option, add CUPS option Approved by: vg (maintainer)
Notes
Notes: svn path=/head/; revision=334853
Diffstat (limited to 'print/qpdfview')
-rw-r--r--print/qpdfview/Makefile61
-rw-r--r--print/qpdfview/pkg-descr4
-rw-r--r--print/qpdfview/pkg-plist1
3 files changed, 25 insertions, 41 deletions
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index a2d03546bf74..69c81f827904 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -7,59 +7,40 @@ CATEGORIES= print
MASTER_SITES= https://launchpadlibrarian.net/140746246/
MAINTAINER= vg@FreeBSD.org
-COMMENT= Tabbed PDF viewer using the poppler library
+COMMENT= Tabbed DjVu/PDF/PS document viewer
LICENSE= GPLv2
-LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
- cups:${PORTSDIR}/print/cups-client
-
-USES= pkgconfig
-USE_QT4= corelib dbus gui imageformats linguist_build moc_build \
- qmake_build rcc_build sql sql-sqlite3_run svg xml
-QMAKEFLAGS+= QMAKE_CFLAGS_RELEASE="" QMAKE_CXXFLAGS_RELEASE=""
+USES= desktop-file-utils pkgconfig qmake
+USE_QT4= corelib dbus gui imageformats_run linguist_build moc_build \
+ rcc_build sql sql-sqlite3_run svg xml
+QMAKE_ARGS+= QMAKE_CFLAGS_RELEASE="" QMAKE_CXXFLAGS_RELEASE=""
+QMAKE_SOURCE_PATH= ${PORTNAME}.pro
DATADIR= ${PREFIX}/share/${PORTNAME}
-MAN1= ${PORTNAME}.1
-
-OPTIONS_DEFINE= DJVU PDF PS
-DJVU_DESC= DjVu support
-PS_DESC= PostScript support
-OPTIONS_DEFAULT= PDF
+OPTIONS_DEFINE= CUPS
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= DJVU PDF PS
+BACKEND_DESC= Documents support
+OPTIONS_DEFAULT= CUPS PDF
+OPTIONS_SUB= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+CUPS_QMAKE_OFF= "CONFIG+=without_cups"
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
-.if ${PORT_OPTIONS:MDJVU}
-PLIST_SUB+= DJVU=""
-LIB_DEPENDS+= djvulibre:${PORTSDIR}/graphics/djvulibre
-.else
-QMAKEFLAGS+= "CONFIG+=without_djvu"
-PLIST_SUB+= DJVU="@comment "
-.endif
+DJVU_LIB_DEPENDS= libdjvulibre.so:${PORTSDIR}/graphics/djvulibre
+DJVU_QMAKE_OFF= "CONFIG+=without_djvu"
-.if ${PORT_OPTIONS:MPDF}
-PLIST_SUB+= PDF=""
-.else
-QMAKEFLAGS+= "CONFIG+=without_pdf"
-PLIST_SUB+= PDF="@comment "
-.endif
+PDF_LIB_DEPENDS= libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
+PDF_QMAKE_OFF= "CONFIG+=without_pdf"
-.if ${PORT_OPTIONS:MPS}
-PLIST_SUB+= PS=""
-LIB_DEPENDS+= spectre:${PORTSDIR}/print/libspectre
-.else
-QMAKEFLAGS+= "CONFIG+=without_ps"
-PLIST_SUB+= PS="@comment "
-.endif
+PS_LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre
+PS_QMAKE_OFF= "CONFIG+=without_ps"
pre-configure:
${REINPLACE_CMD} -e 's#/usr#${PREFIX}#g;s#${PREFIX}/share/man#${PREFIX}/man#g' \
${WRKSRC}/${PORTNAME}.pri
-
-do-configure:
- cd ${WRKSRC} && lrelease-qt4 ${PORTNAME}.pro
- cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS} ${PORTNAME}.pro
+ cd ${WRKSRC} && ${LRELEASE} ${PORTNAME}.pro
.include <bsd.port.mk>
diff --git a/print/qpdfview/pkg-descr b/print/qpdfview/pkg-descr
index fb3d28efaa6b..6d3deb359d40 100644
--- a/print/qpdfview/pkg-descr
+++ b/print/qpdfview/pkg-descr
@@ -1,3 +1,5 @@
-qpdfview is a tabbed PDF viewer using the poppler library.
+qpdfview is a tabbed document viewer. It uses Poppler for PDF
+support, libspectre for PS support, DjVuLibre for DjVu support,
+CUPS for printing support and the Qt toolkit for its interface.
WWW: https://launchpad.net/qpdfview
diff --git a/print/qpdfview/pkg-plist b/print/qpdfview/pkg-plist
index 9f5f35aa2e7a..6511058c72fc 100644
--- a/print/qpdfview/pkg-plist
+++ b/print/qpdfview/pkg-plist
@@ -2,6 +2,7 @@ bin/qpdfview
%%DJVU%%lib/qpdfview/libqpdfview_djvu.so
%%PDF%%lib/qpdfview/libqpdfview_pdf.so
%%PS%%lib/qpdfview/libqpdfview_ps.so
+man/man1/qpdfview.1.gz
share/applications/qpdfview.desktop
%%DATADIR%%/help.html
%%DATADIR%%/qpdfview.svg