aboutsummaryrefslogtreecommitdiff
path: root/print/ruby-panda/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-04-01 21:43:25 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-04-01 21:43:25 +0000
commit8f15e0febd8a2b48774aa4a996dfedafa081d835 (patch)
tree4425a161c851002c1fd5f1ab8eb63ef67b4e215c /print/ruby-panda/Makefile
parente295b0bcd296c0eecc4707b2b25f76eff5fd7f1b (diff)
downloadports-8f15e0febd8a2b48774aa4a996dfedafa081d835.tar.gz
ports-8f15e0febd8a2b48774aa4a996dfedafa081d835.zip
Notes
Diffstat (limited to 'print/ruby-panda/Makefile')
-rw-r--r--print/ruby-panda/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/print/ruby-panda/Makefile b/print/ruby-panda/Makefile
new file mode 100644
index 000000000000..69d3bc015c04
--- /dev/null
+++ b/print/ruby-panda/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: Ruby/Panda
+# Date created: 28 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= panda
+PORTVERSION= 0.0.2
+CATEGORIES= print ruby
+MASTER_SITES= http://www2s.biglobe.ne.jp/~Nori/ruby/dist/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= panda.0:${PORTSDIR}/print/panda \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.4:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CONFIGURE_ARGS= --with-cflags="${PTHREAD_CFLAGS}" \
+ --with-ldflags="${PTHREAD_LIBS}"
+INSTALL_TARGET= site-install
+
+DOCS_EN= README
+DOCS_JA= ChangeLog.ja README.ja TODO.ja
+EXAMPLES_EN= main.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ cd ${RUBY_EXAMPLESDIR}/${PORTNAME} && ${LN} -sf ../../panda/*.jpg ../../panda/*.png ../../panda/*.tif .
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>