aboutsummaryrefslogtreecommitdiff
path: root/print/scribus-devel/Makefile
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-11-15 03:49:20 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-11-15 03:49:20 +0000
commit77a138bfee1961a748eab7f059ee73a09d4f9262 (patch)
tree1fea9df2e7ef891a4b07ca79b6ca5f310bbf73d3 /print/scribus-devel/Makefile
parent7df3c9856efbd0dd265a47a8d7a9090f881be443 (diff)
downloadports-77a138bfee1961a748eab7f059ee73a09d4f9262.tar.gz
ports-77a138bfee1961a748eab7f059ee73a09d4f9262.zip
Notes
Diffstat (limited to 'print/scribus-devel/Makefile')
-rw-r--r--print/scribus-devel/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index d380cfb2a9d3..32fcf257e57e 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -7,28 +7,31 @@
#
PORTNAME= scribus
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9.1
+PORTREVISION= 0
CATEGORIES= print editors
MASTER_SITES= http://web2.altmuehlnet.de/fschmid/
DIST_SUBDIR= ${PORTNAME}
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= Fonts.diff Palette.diff
-PATCH_DIST_STRIP= -p1
+#PATCH_SITES= ${MASTER_SITES}
+#PATCHFILES=
+#PATCH_DIST_STRIP= -p1
-MAINTAINER= alane@freebsd.org
+MAINTAINER= freebsd-ports@freebsd.org
RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
+BROKEN= "crashes on startup"
+
USE_QT_VER= 3
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/share/scribus/libs \
%%PREFIX%%/share/scribus/plugins
-BROKEN= "This program terminates with a SIGBUS or simply hangs"
+QTCFGLIBS+= -lm
post-patch::
${FIND} ${WRKSRC} -type f \
@@ -42,8 +45,8 @@ post-patch::
${WRKSRC}/scribus/Makefile.in
.endif # defined(NOPORTDOCS)
-post-configure::
- ${FIND} ${WRKSRC} -name Makefile \
- |${XARGS} -n 1 ${REINPLACE_CMD} -e 's|-O2||g'
+#post-configure::
+# ${FIND} ${WRKSRC} -name Makefile \
+# |${XARGS} -n 1 ${REINPLACE_CMD} -e 's|-O2||g'
.include <bsd.port.mk>