aboutsummaryrefslogtreecommitdiff
path: root/print/scribus/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-30 22:31:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-30 22:31:29 +0000
commit52bfcc93297feb1e74937e2e4b4ba31b907f244b (patch)
treee9abe5e4afb4a44057ab0fe18c4666a7437a47cb /print/scribus/Makefile
parent2f5c5d6e85dce4622053b7bc2da5aa84af1747d9 (diff)
Notes
Diffstat (limited to 'print/scribus/Makefile')
-rw-r--r--print/scribus/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 0c77b675ccb1..59b365764691 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -7,32 +7,33 @@
#
PORTNAME= scribus
-PORTVERSION= 1.2.4.1
-PORTREVISION= 1
+PORTVERSION= 1.3.3.1
CATEGORIES= print editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.scribus.org.uk/downloads/${PORTVERSION}/
+ http://www.scribus.net/downloads/${PORTVERSION}/
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rainer.alves@gmail.com
COMMENT= A comprehensive desktop publishing program
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
tiff.4:${PORTSDIR}/graphics/tiff \
cups.2:${PORTSDIR}/print/cups-base \
freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
+ ${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
USE_BZIP2= yes
USE_QT_VER= 3
+USE_GCC= 3.3+
USE_GNOME= gnometarget libartlgpl2 libxml2
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
+PLIST_SUB+= SCRIBUS_VERSION=${PORTVERSION}
MAN1= scribus.1
MANLANG= "" pl
@@ -42,14 +43,6 @@ MANLANG= "" pl
CXXFLAGS+= -fpermissive
.endif
-pre-everything::
-.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
- @${ECHO_MSG} ""
- @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
- @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
- @${ECHO_MSG} ""
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g; \
s|-O2 ||g ; \