aboutsummaryrefslogtreecommitdiff
path: root/print/texinfo/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-06-11 11:46:39 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-06-11 11:46:39 +0000
commitc9f153c75bd52a50a1219f535d7c3b3b91ff4b24 (patch)
tree78c7e89bb5724474209d67d45af5f63c4eebe717 /print/texinfo/Makefile
parentee057a586953b6cda289a1572f0e79d07c7b3dc7 (diff)
downloadports-c9f153c75bd52a50a1219f535d7c3b3b91ff4b24.tar.gz
ports-c9f153c75bd52a50a1219f535d7c3b3b91ff4b24.zip
Notes
Diffstat (limited to 'print/texinfo/Makefile')
-rw-r--r--print/texinfo/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index 378bd826c83f..2c3fbfee0b40 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -6,14 +6,22 @@
#
PORTNAME= texinfo
-PORTVERSION= 4.13
+PORTVERSION= 4.13.20110529
CATEGORIES= print
-MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ ftp://ftp.stack.nl/pub/users/johans/texinfo/${PORTVERSION:E}/
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} texinfo.tex texi2dvi
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= A typeset documentation system with multiple format output
+BUILD_DEPENDS+= help2man:${PORTSDIR}/misc/help2man
+
+CONFLICTS_INSTALL=teTeX-base-[0-9]*
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALL_TARGET= install install-tex
@@ -21,11 +29,9 @@ PKGDEINSTALL= ${PKGINSTALL}
MAKE_JOBS_SAFE= yes
MAKE_ARGS= TEXMF=${PREFIX}/${TEXMFLOCAL}
-CONFIGURE_ARGS= \
- --without-included-gettext
-CONFIGURE_ENV= \
- CPPFLAGS="-I${LOCALBASE}/lib" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS= --without-included-gettext
+CPPFLAGS= -I${LOCALBASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib -lintl
INFO= ${PORTNAME} info-stnd info
MAN1= info.1 infokey.1 install-info.1 makeinfo.1 texi2dvi.1 \
@@ -48,6 +54,8 @@ PLIST_SUB+= NLS=""
post-patch:
${CHMOD} 755 ${WRKSRC}/build-aux/install-sh
+ ${CP} ${DISTDIR}/texinfo.tex ${WRKSRC}/doc/
+ ${CP} ${DISTDIR}/texi2dvi ${WRKSRC}/util/
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} ${SH} \