aboutsummaryrefslogtreecommitdiff
path: root/print/texinfo
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-17 23:56:12 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-17 23:56:12 +0000
commitbb753745ce120a725a5dd81535069c6b75d927ab (patch)
tree87fc3896933716e18d691c5e3a08652a5b5ef434 /print/texinfo
parent610b3ee9d1c1b7fb24dcff66f0a709b832d2b936 (diff)
downloadports-bb753745ce120a725a5dd81535069c6b75d927ab.tar.gz
ports-bb753745ce120a725a5dd81535069c6b75d927ab.zip
Notes
Diffstat (limited to 'print/texinfo')
-rw-r--r--print/texinfo/Makefile2
-rw-r--r--print/texinfo/files/patch-util__texindex.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index c99f87d5f66a..ce4b75a02ce3 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= texinfo
PORTVERSION= 4.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/print/texinfo/files/patch-util__texindex.c b/print/texinfo/files/patch-util__texindex.c
new file mode 100644
index 000000000000..8e8d076f57a8
--- /dev/null
+++ b/print/texinfo/files/patch-util__texindex.c
@@ -0,0 +1,26 @@
+--- util/texindex.c.orig Mon Oct 17 21:41:08 2005
++++ util/texindex.c Mon Oct 17 21:41:52 2005
+@@ -390,7 +390,9 @@
+ maketempname (int count)
+ {
+ static char *tempbase = NULL;
++ char *tempname;
+ char tempsuffix[10];
++ int fd;
+
+ if (!tempbase)
+ {
+@@ -403,7 +405,12 @@
+ }
+
+ sprintf (tempsuffix, ".%d", count);
+- return concat (tempbase, tempsuffix);
++ tempname = concat (tempbase, tempsuffix);
++ fd = open (tempname, O_CREAT|O_EXCL|O_WRONLY, 0600);
++ if (fd == -1)
++ pfatal_with_name (tempname);
++ close (fd);
++ return tempname;
+ }
+
+