aboutsummaryrefslogtreecommitdiff
path: root/print/ttfquery
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-14 08:42:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-14 08:42:30 +0000
commit874f34a00625ed43e73ffadcd56ddcd0a4217e44 (patch)
treef9eb6d87aa967db3450598a7b50d5aab3883be0c /print/ttfquery
parent68f2f01e8031441f5374196ceb49c2fc6e228dd7 (diff)
downloadports-874f34a00625ed43e73ffadcd56ddcd0a4217e44.tar.gz
ports-874f34a00625ed43e73ffadcd56ddcd0a4217e44.zip
Notes
Diffstat (limited to 'print/ttfquery')
-rw-r--r--print/ttfquery/Makefile7
-rw-r--r--print/ttfquery/distinfo6
-rw-r--r--print/ttfquery/files/patch-setup.py26
3 files changed, 32 insertions, 7 deletions
diff --git a/print/ttfquery/Makefile b/print/ttfquery/Makefile
index 00457421a538..5567730bc283 100644
--- a/print/ttfquery/Makefile
+++ b/print/ttfquery/Makefile
@@ -7,17 +7,16 @@
#
PORTNAME= ttfquery
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= print
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= TTFQuery-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FontTools-based package for querying system fonts
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/FontTools.pth:${PORTSDIR}/print/py-fonttools \
- ${PYNUMERIC}
+ ${PYNUMPY}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/print/ttfquery/distinfo b/print/ttfquery/distinfo
index fb0f91ff3a2e..a751e670b51b 100644
--- a/print/ttfquery/distinfo
+++ b/print/ttfquery/distinfo
@@ -1,3 +1,3 @@
-MD5 (TTFQuery-1.0.0.tar.gz) = 33422cdeb5bf47701df2459b8d5889c4
-SHA256 (TTFQuery-1.0.0.tar.gz) = 4273507f84bb818f13bdab1aea6df4bb8f25e7602cb24e290c4466dc465ebd2a
-SIZE (TTFQuery-1.0.0.tar.gz) = 15947
+MD5 (TTFQuery-1.0.1.tar.gz) = aa4e71e4a21c97341003831530356f5e
+SHA256 (TTFQuery-1.0.1.tar.gz) = 3dd30b330467f59e4b184c902bf999ce9d864741f3ab7539682896e7c16d09a5
+SIZE (TTFQuery-1.0.1.tar.gz) = 18346
diff --git a/print/ttfquery/files/patch-setup.py b/print/ttfquery/files/patch-setup.py
new file mode 100644
index 000000000000..1d63708da799
--- /dev/null
+++ b/print/ttfquery/files/patch-setup.py
@@ -0,0 +1,26 @@
+--- setup.py.orig 2008-01-02 11:51:03.000000000 +0900
++++ setup.py 2008-09-11 12:22:49.000000000 +0900
+@@ -6,7 +6,7 @@
+ to install the package from the source archive.
+ """
+ import sys,os, string
+-from setuptools import setup
++from distutils.core import setup
+ from sys import hexversion
+
+ if __name__ == "__main__":
+@@ -59,14 +59,6 @@
+ author_email = "mcfletch@users.sourceforge.net",
+ url = "http://ttfquery.sourceforge.net/",
+ license = "BSD-style, see license.txt for details",
+- include_package_data = True,
+-
+- zip_safe=True,
+- install_requires = ['FontTools-numpy'],
+- dependency_links = [
+- # TTFQuery/FontTools-numpy
+- "https://sourceforge.net/project/showfiles.php?group_id=84080",
+- ],
+
+
+ package_dir = {