aboutsummaryrefslogtreecommitdiff
path: root/print/txtbdf2ps/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-10 04:35:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-10 04:35:29 +0000
commit85f8ed6f8f36d1ce57ab8c188aa57435a074fef2 (patch)
treeeb7571242f35869e53bf96d6f6afa50c8b840a0c /print/txtbdf2ps/Makefile
parent8a583ac17ad7844ca5c0f130fbc8df89d21f944d (diff)
downloadports-85f8ed6f8f36d1ce57ab8c188aa57435a074fef2.tar.gz
ports-85f8ed6f8f36d1ce57ab8c188aa57435a074fef2.zip
Notes
Diffstat (limited to 'print/txtbdf2ps/Makefile')
-rw-r--r--print/txtbdf2ps/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/print/txtbdf2ps/Makefile b/print/txtbdf2ps/Makefile
new file mode 100644
index 000000000000..4dc5403d05bf
--- /dev/null
+++ b/print/txtbdf2ps/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: txtbdf2ps
+# Date created: Aug 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= txtbdf2ps
+PORTVERSION= 0.7.1
+CATEGORIES= print
+MASTER_SITES= http://www.geocities.com/CapeCanaveral/Lab/5735/1/ \
+ http://oldrus-ispell.sourceforge.net/ \
+ http://members.fortunecity.com/brodsky/TL/LS/ \
+ http://sawsoft.newmail.ru/LS/
+EXTRACT_SUFX= .txt
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/bin/perl|${PERL}|g" ${WRKSRC}/${DISTNAME}.txt
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME}.txt ${PREFIX}/bin/txtbdf2ps
+
+.include <bsd.port.mk>