aboutsummaryrefslogtreecommitdiff
path: root/print/virtualpaper
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1996-06-14 08:00:15 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1996-06-14 08:00:15 +0000
commit6b6e6fb90b732403569d841ad0b27131081a0049 (patch)
treee4ab548165c2d733338fc4f00c0cb041ce3f03ec /print/virtualpaper
parent15a2b1216361bd774f9734942d926138744a8857 (diff)
downloadports-6b6e6fb90b732403569d841ad0b27131081a0049.tar.gz
ports-6b6e6fb90b732403569d841ad0b27131081a0049.zip
Notes
Diffstat (limited to 'print/virtualpaper')
-rw-r--r--print/virtualpaper/Makefile33
-rw-r--r--print/virtualpaper/distinfo1
-rw-r--r--print/virtualpaper/pkg-comment1
-rw-r--r--print/virtualpaper/pkg-descr26
-rw-r--r--print/virtualpaper/pkg-plist104
5 files changed, 165 insertions, 0 deletions
diff --git a/print/virtualpaper/Makefile b/print/virtualpaper/Makefile
new file mode 100644
index 000000000000..1e9777d51451
--- /dev/null
+++ b/print/virtualpaper/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: virtualpaper
+# Version required: 1.2
+# Date created: 13 June 1996
+# Whom: jkh
+#
+# $Id: Makefile,v 1.6 1996/04/18 07:58:21 tg Exp $
+#
+
+DISTNAME= virtualpaper-1.3
+CATEGORIES+= print
+DISTFILES= sources.tar.Z
+MASTER_SITES= http://www.research.digital.com:80/SRC/virtualpaper/cgi-bin/nph-download.tcl/sources.tar.Z?object=Virtual+Paper/
+BUILD_DEPENDS= m3build:${PORTSDIR}/lang/modula-3
+RUN_DEPENDS= m3ship:${PORTSDIR}/lang/modula-3
+
+do-build:
+ @(cd ${WRKSRC}/lecternclient ; m3build)
+ @(cd ${WRKSRC}/lecterndoc; m3build)
+ @(cd ${WRKSRC}/lectern; m3build)
+ @(cd ${WRKSRC}/ocr; m3build)
+ @(cd ${WRKSRC}/buildlectern; m3build)
+ @(cd ${WRKSRC}/editlectern; m3build)
+
+do-install:
+ @(cd ${WRKSRC}/lecternclient ; m3ship)
+ @(cd ${WRKSRC}/lecterndoc; m3ship)
+ @(cd ${WRKSRC}/lectern; m3ship)
+ @(cd ${WRKSRC}/ocr; m3ship)
+ @(cd ${WRKSRC}/buildlectern; m3ship)
+ @(cd ${WRKSRC}/editlectern; m3ship)
+ @/sbin/ldconfig -m ${PREFIX}/lib/m3/FreeBSD2
+
+.include <bsd.port.mk>
diff --git a/print/virtualpaper/distinfo b/print/virtualpaper/distinfo
new file mode 100644
index 000000000000..bd001cdf5051
--- /dev/null
+++ b/print/virtualpaper/distinfo
@@ -0,0 +1 @@
+MD5 (sources.tar.Z) = 6512f760a6bc7f58d5f82fd4a836557c
diff --git a/print/virtualpaper/pkg-comment b/print/virtualpaper/pkg-comment
new file mode 100644
index 000000000000..8bf4f2fa000c
--- /dev/null
+++ b/print/virtualpaper/pkg-comment
@@ -0,0 +1 @@
+Virtual Paper document storage and viewing software.
diff --git a/print/virtualpaper/pkg-descr b/print/virtualpaper/pkg-descr
new file mode 100644
index 000000000000..6aaaef957d13
--- /dev/null
+++ b/print/virtualpaper/pkg-descr
@@ -0,0 +1,26 @@
+The Virtual Paper software centers around the notion of a document, which
+generally corresponds to a single paper, report, or book. A document is
+stored as a single file, in a format that we call a "Lectern document". The
+application "BuildLectern" constructs these documents, and "Lectern" lets you
+view them on your computer.
+
+A Lectern document contains images of each page of the document (at several
+scales), text for the pages (for searching, not for viewing), and global
+information about the document (such as a copy of a PostScript version of the
+document, if available).
+
+A Lectern document has a fairly simple internal structure. There's an
+internal directory, and a set of components. The components each contain the
+bytes for some part of the overall document: a single page image at a
+particular scale, or the text for a single page, or the PostScript that was
+used to create the document.
+
+BuildLectern generates a single Lectern document. Its input can be a
+PostScript file, or parts of previously built Lectern documents. Or its
+input can be original raster-based images (such as a set of TIFF files),
+typically at a moderate resolution such as 300 DPI. Finally, BuildLectern's
+input can be a combination of all of these.
+
+For more information, please see:
+
+ http://www.research.digital.com:80/SRC/virtualpaper
diff --git a/print/virtualpaper/pkg-plist b/print/virtualpaper/pkg-plist
new file mode 100644
index 000000000000..cdfac1628639
--- /dev/null
+++ b/print/virtualpaper/pkg-plist
@@ -0,0 +1,104 @@
+bin/LecternClient
+bin/Lectern
+bin/BuildLectern
+bin/EditLectern
+man/man1/Lectern.1
+man/man1/EditLectern.1
+man/man1/LecternClient.1
+man/man1/BuildLectern.1
+lib/m3/FreeBSD2/libm3smalldb.so.353.0
+lib/m3/FreeBSD2/libm3core.so.353.0
+lib/m3/FreeBSD2/libm3configvars.so.353.0
+lib/m3/FreeBSD2/libm3.so.353.0
+lib/m3/FreeBSD2/libset.so.353.0
+lib/m3/FreeBSD2/libGeometry.so.353.0
+lib/m3/FreeBSD2/libm3parseparams.so.353.0
+lib/m3/FreeBSD2/libm3slisp.so.353.0
+lib/m3/FreeBSD2/libTempFiles.so.353.0
+lib/m3/FreeBSD2/libm3tcp.so.353.0
+lib/m3/FreeBSD2/libm3netobj.so.353.0
+lib/m3/FreeBSD2/libm3tk.so.353.0
+lib/m3/FreeBSD2/libstable.so.353.0
+lib/m3/FreeBSD2/libm3X11R4.so.353.0
+lib/m3/FreeBSD2/libPEX.so.353.0
+lib/m3/FreeBSD2/libm3ui.so.353.0
+lib/m3/FreeBSD2/libm3bicycle.so.353.0
+lib/m3/FreeBSD2/libm3tools.so.353.0
+lib/m3/FreeBSD2/libm3vbtkit.so.353.0
+lib/m3/FreeBSD2/libImages.so.353.0
+lib/m3/FreeBSD2/libjvideo.so.353.0
+lib/m3/FreeBSD2/libvideovbt.so.353.0
+lib/m3/FreeBSD2/libm3formsvbtpixmaps.so.353.0
+lib/m3/FreeBSD2/libm3formsvbt.so.353.0
+lib/m3/FreeBSD2/libm3codeview.so.353.0
+lib/m3/FreeBSD2/libm3mg.so.353.0
+lib/m3/FreeBSD2/libm3mgkit.so.353.0
+lib/m3/FreeBSD2/libanim3D.so.353.0
+lib/m3/FreeBSD2/libsynwr.so.353.0
+lib/m3/FreeBSD2/libsynex.so.353.0
+lib/m3/FreeBSD2/libmetasyn.so.353.0
+lib/m3/FreeBSD2/libobliqrt.so.353.0
+lib/m3/FreeBSD2/libobliqlibm3.so.353.0
+lib/m3/FreeBSD2/libobliqlibui.so.353.0
+lib/m3/FreeBSD2/libobliqlibanim.so.353.0
+lib/m3/FreeBSD2/libobliqparse.so.353.0
+lib/m3/FreeBSD2/libobliqprint.so.353.0
+lib/m3/FreeBSD2/libobliq.so.353.0
+lib/m3/FreeBSD2/libobliqlib3D.so.353.0
+lib/m3/FreeBSD2/libm3zeus.so.353.0
+lib/m3/FreeBSD2/liblecternserver.so.353.0
+lib/m3/FreeBSD2/libLecternDoc.so.353.0
+lib/m3/FreeBSD2/libocr.so.353.0
+lib/m3/pkg/lecternclient/FreeBSD2/.M3EXPORTS
+lib/m3/pkg/lecternclient/FreeBSD2/.M3IMPTAB
+lib/m3/pkg/lecternclient/FreeBSD2/.M3WEB
+lib/m3/pkg/lecternclient/FreeBSD2/liblecternserver.a
+lib/m3/pkg/lecternclient/FreeBSD2/liblecternserver.m3x
+lib/m3/pkg/lecternclient/FreeBSD2/liblecternserver.so.353.0
+lib/m3/pkg/lecternclient/src/LecternServer.i3
+lib/m3/pkg/lecternclient/src/LecternClient.i3
+lib/m3/pkg/lecterndoc/FreeBSD2/.M3EXPORTS
+lib/m3/pkg/lecterndoc/FreeBSD2/.M3IMPTAB
+lib/m3/pkg/lecterndoc/FreeBSD2/.M3WEB
+lib/m3/pkg/lecterndoc/FreeBSD2/libLecternDoc.a
+lib/m3/pkg/lecterndoc/FreeBSD2/libLecternDoc.m3x
+lib/m3/pkg/lecterndoc/FreeBSD2/libLecternDoc.so.353.0
+lib/m3/pkg/lecterndoc/src/LecternDoc.i3
+lib/m3/pkg/lectern/FreeBSD2/.M3EXPORTS
+lib/m3/pkg/lectern/FreeBSD2/.M3IMPTAB
+lib/m3/pkg/lectern/FreeBSD2/.M3WEB
+lib/m3/pkg/lectern/FreeBSD2/LecternBundle.i3
+lib/m3/pkg/lectern/src/Links.i3
+lib/m3/pkg/lectern/src/ViewAreaVBT.i3
+lib/m3/pkg/lectern/src/ThumbnailVBT.i3
+lib/m3/pkg/lectern/src/LecternOCR.i3
+lib/m3/pkg/lectern/src/MyFileBrowserVBT.i3
+lib/m3/pkg/lectern/src/Find.i3
+lib/m3/pkg/ocr/FreeBSD2/.M3EXPORTS
+lib/m3/pkg/ocr/FreeBSD2/.M3IMPTAB
+lib/m3/pkg/ocr/FreeBSD2/.M3WEB
+lib/m3/pkg/ocr/FreeBSD2/libocr.a
+lib/m3/pkg/ocr/FreeBSD2/libocr.m3x
+lib/m3/pkg/ocr/FreeBSD2/libocr.so.353.0
+lib/m3/pkg/ocr/src/Common/OCR.i3
+lib/m3/pkg/buildlectern/FreeBSD2/.M3EXPORTS
+lib/m3/pkg/buildlectern/FreeBSD2/.M3IMPTAB
+lib/m3/pkg/buildlectern/FreeBSD2/.M3WEB
+lib/m3/pkg/buildlectern/FreeBSD2/FromPSBundle.i3
+lib/m3/pkg/buildlectern/FreeBSD2/BBoxSeqRep.i3
+lib/m3/pkg/buildlectern/FreeBSD2/BBoxSeq.i3
+lib/m3/pkg/buildlectern/src/OCR_PS.i3
+lib/m3/pkg/buildlectern/src/OSUtils.i3
+lib/m3/pkg/buildlectern/src/Cscale.i3
+lib/m3/pkg/buildlectern/src/BBox.i3
+lib/m3/pkg/buildlectern/src/LGM.i3
+lib/m3/pkg/buildlectern/src/FromPS.i3
+lib/m3/pkg/editlectern/FreeBSD2/.M3EXPORTS
+lib/m3/pkg/editlectern/FreeBSD2/.M3IMPTAB
+lib/m3/pkg/editlectern/FreeBSD2/.M3WEB
+lib/m3/pkg/editlectern/FreeBSD2/EditLecternBundle.i3
+lib/m3/www/LecternClient.1.html
+lib/m3/www/Lectern.1.html
+lib/m3/www/BuildLectern.1.html
+lib/m3/www/EditLectern.1.html
+@exec /sbin/ldconfig -m %D/lib/m3/pkg/FreeBSD2