aboutsummaryrefslogtreecommitdiff
path: root/print/xpp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-11-08 20:52:59 +0000
committerCy Schubert <cy@FreeBSD.org>2016-11-08 20:52:59 +0000
commit580eeb805aafee6ff4900639d398b0831007dcf4 (patch)
treebcc8b5fc0e7f97810a8e0a8bef443631a28b0c57 /print/xpp
parent672cf591e994a63951b1c5f66428f0d81f714803 (diff)
downloadports-580eeb805aafee6ff4900639d398b0831007dcf4.tar.gz
ports-580eeb805aafee6ff4900639d398b0831007dcf4.zip
Notes
Diffstat (limited to 'print/xpp')
-rw-r--r--print/xpp/Makefile2
-rw-r--r--print/xpp/files/patch-xpp.cxx32
2 files changed, 30 insertions, 4 deletions
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
index 3211ee638ba5..7654717aa68d 100644
--- a/print/xpp/Makefile
+++ b/print/xpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xpp
PORTVERSION= 1.5
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= print
MASTER_SITES= SF/cups/${PORTNAME}/${PORTVERSION}
diff --git a/print/xpp/files/patch-xpp.cxx b/print/xpp/files/patch-xpp.cxx
index 2d1c5c875711..e972adc2464b 100644
--- a/print/xpp/files/patch-xpp.cxx
+++ b/print/xpp/files/patch-xpp.cxx
@@ -1,6 +1,32 @@
--- xpp.cxx.orig 2004-12-06 11:00:04.000000000 -0800
-+++ xpp.cxx 2011-12-03 22:11:00.788941301 -0800
-@@ -2500,7 +2500,7 @@
++++ xpp.cxx 2016-11-08 12:49:34.251265000 -0800
+@@ -30,6 +30,7 @@
+ * Include necessary headers...
+ */
+
++#include <stdio.h>
+ #include "xpp.h"
+
+ #ifndef WIN32
+@@ -48,7 +49,7 @@
+ * Globals...
+ */
+
+-char tempfile[1024]; /* Temporary file for printing from stdin */
++static char *tempfile; /* Temporary file for printing from stdin */
+
+ /*
+ * Parse options and send files for printing.
+@@ -651,7 +652,7 @@
+ #endif
+ #endif // !WIN32
+
+- temp = fopen(cupsTempFile(tempfile, sizeof(tempfile)), "w");
++ temp = fopen((tempfile = tmpnam(NULL)), "w");
+
+ if (temp == NULL)
+ {
+@@ -2500,7 +2501,7 @@
// Redraw the destination menu in the main window
printerPack->parent()->redraw();
@@ -9,7 +35,7 @@
}
-@@ -2674,7 +2674,7 @@
+@@ -2674,7 +2675,7 @@
// Redraw the destination menu in the main window
printerPack->parent()->redraw();