aboutsummaryrefslogtreecommitdiff
path: root/print/xpp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-11-29 21:15:20 +0000
committerCy Schubert <cy@FreeBSD.org>2011-11-29 21:15:20 +0000
commit0c1de55039cb70d9e91db2eac6fae60f84e2587c (patch)
tree752363187fd80e4b8138a5c087ecd01075d67a20 /print/xpp
parent3d82b066a6625b2d75e902aefc1162b0747515ac (diff)
downloadports-0c1de55039cb70d9e91db2eac6fae60f84e2587c.tar.gz
ports-0c1de55039cb70d9e91db2eac6fae60f84e2587c.zip
Notes
Diffstat (limited to 'print/xpp')
-rw-r--r--print/xpp/Makefile7
-rw-r--r--print/xpp/files/patch-cupshelper.h10
-rw-r--r--print/xpp/files/patch-xpp.h10
3 files changed, 22 insertions, 5 deletions
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
index 21ea4499569e..472085530c1c 100644
--- a/print/xpp/Makefile
+++ b/print/xpp/Makefile
@@ -7,20 +7,17 @@
PORTNAME= xpp
PORTVERSION= 1.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= print
MASTER_SITES= SF/cups/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= X11-based printer manager for CUPS
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
BUILD_DEPENDS= ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
-BROKEN= does not compile
-EXPIRATION_DATE= 2011-11-30
-
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/print/xpp/files/patch-cupshelper.h b/print/xpp/files/patch-cupshelper.h
new file mode 100644
index 000000000000..3e4d2052b903
--- /dev/null
+++ b/print/xpp/files/patch-cupshelper.h
@@ -0,0 +1,10 @@
+--- cupshelper.h.orig 2002-05-28 08:49:45.000000000 -0700
++++ cupshelper.h 2011-11-29 13:10:22.991997261 -0800
+@@ -34,6 +34,7 @@
+ #define CUPSHELPER_H
+
+ #include <cups/cups.h>
++#include <cups/ppd.h>
+ #include <cups/ipp.h>
+
+ const char* cupsGetPassword(const char *prompt);
diff --git a/print/xpp/files/patch-xpp.h b/print/xpp/files/patch-xpp.h
new file mode 100644
index 000000000000..94a77814e6a7
--- /dev/null
+++ b/print/xpp/files/patch-xpp.h
@@ -0,0 +1,10 @@
+--- xpp.h.orig 2011-11-29 13:02:26.198230347 -0800
++++ xpp.h 2011-11-29 13:07:43.783229272 -0800
+@@ -34,6 +34,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <cups/cups.h>
++#include <cups/ppd.h>
+ #include <cups/ipp.h>
+ #include <cups/language.h>
+ #include <FL/Fl.H>