aboutsummaryrefslogtreecommitdiff
path: root/print/xreader/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-03 13:22:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-03 13:22:28 +0000
commit664a5424a2d29c57a3fb4063787b9d9b2899912a (patch)
tree7e73454697e0fdca88332e41c9955dbef7a4be77 /print/xreader/Makefile
parentad8ad2b15d0857bba452c779ed0cd1d2ce161ae3 (diff)
downloadports-664a5424a2d29c57a3fb4063787b9d9b2899912a.tar.gz
ports-664a5424a2d29c57a3fb4063787b9d9b2899912a.zip
Notes
Diffstat (limited to 'print/xreader/Makefile')
-rw-r--r--print/xreader/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/print/xreader/Makefile b/print/xreader/Makefile
new file mode 100644
index 000000000000..0aca321c7ee1
--- /dev/null
+++ b/print/xreader/Makefile
@@ -0,0 +1,55 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xreader
+PORTVERSION= 2.4.4
+CATEGORIES= print
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Generic document reader
+
+LICENSE= GPLv2+
+
+BUILD_DEPENDS= intltool-merge:textproc/intltool
+LIB_DEPENDS= libxapp.so:x11/xapps
+
+USES= desktop-file-utils gettext-tools gnome meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+USE_LDCONFIG= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30 libxml2
+USE_XORG= ice sm x11
+GLIB_SCHEMAS= org.x.reader.gschema.xml
+INSTALLS_ICONS= yes
+
+MESON_ARGS= -Depub=false -Dtests=false
+
+OPTIONS_DEFINE= DJVU KEYRING PDF PS TIFF XPS
+OPTIONS_DEFAULT= DJVU KEYRING PDF TIFF XPS
+KEYRING_DESC= Password-protected document support
+XPS_DESC= XPS document support
+OPTIONS_SUB= yes
+
+DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
+DJVU_MESON_ON= -Ddjvu=true
+
+KEYRING_LIB_DEPENDS= libsecret-1.so:security/libsecret
+KEYRING_MESON_OFF= -Dkeyring=false
+
+PDF_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+PDF_MESON_OFF= -Dpdf=false
+
+PS_LIB_DEPENDS= libspectre.so:print/libspectre
+PS_MESON_OFF= -Dps=false
+
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_MESON_OFF= -Dtiff=false
+
+XPS_LIB_DEPENDS= libgxps.so:graphics/libgxps
+XPS_MESON_OFF= -Dxps=false
+
+post-patch:
+ @${REINPLACE_CMD} -e '/gdk\/gdkwayland\.h/d' \
+ ${WRKSRC}/libdocument/ev-document-misc.h
+
+.include <bsd.port.mk>